Bug 17580 - Настройка X-сервера
: Настройка X-сервера
Status: NEW
: ALT Linux Desktop
(All bugs in ALT Linux Desktop/bugs)
: 4.1.0
: all Linux
: P2 normal
Assigned To:
:
:
:
:
:
  Show dependency tree
 
Reported: 2008-10-15 15:03 by
Modified: 2008-10-18 08:37 (History)


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2008-10-15 15:03:52
Ситуация следующая: Мой монитор SyncMaster 940nw. В файле xorg.conf для него
прописаны все нужные настройки вот так: Section "Monitor"
    Identifier   "Samsung SyncMaster 940nw|0"
    DisplaySize  410    260
    HorizSync    30.0 - 81.0
    VertRefresh  56.0 - 75.0
    ModeLine     "1440x900" 106.5 1440 1520 1672 1904 900 903 909 934

Но при загрузке X-сервера все равно начальное разрешение экрана имею 1440х1024!
Почему? Приходится в KDE при первом запуске менять разрешение и требовать, что
бы это разрешение грузилось при следующем запуске KDE, но kdm мне все равно
постоянно выставляет 1440x1024... 
в acc стоит разрешение 1440x900... нажимаю кнопку "проверить" и имею тестовый
экран с разрешением 1440x1024
попробовал поставить в acc "авто", и все встало на свои места... разрешение
тестовой картинки 1440x900 и разрешение kdm такое же!
------- Comment #1 From 2008-10-17 19:37:46 -------
давайте спросим мантейнера xorg ... ведь modeline вы сами писали, а это вообще
говоря не нужно нынче делать.
------- Comment #2 From 2008-10-17 20:49:34 -------
1. какая видео карта?
2. какой драйвер?
3. еще где то это моделайн фигурирует?
------- Comment #3 From 2008-10-18 08:27:26 -------
(In reply to comment #1)
> давайте спросим мантейнера xorg ... ведь modeline вы сами писали, а это вообще
> говоря не нужно нынче делать.
> 
Modeline писал самостоятельно, только потому, что пытался исправить ситуацию -
не помогло. С умолчальными настройками xorg.conf была та же самая история.
------- Comment #4 From 2008-10-18 08:30:31 -------
(In reply to comment #2)
> 1. какая видео карта?
> 2. какой драйвер?
> 3. еще где то это моделайн фигурирует?
> 

Nvidia GeForce 440
Драйвер именно тот, который система выбрала автоматически, я так понимаю -
прориетарный nvidia, при загрузке X-сервера пролетает логотип. Моделайн не
фигурирует больше нигде. Но если его убрать, то абсолютно ничего не изменится,
пробовал!
------- Comment #5 From 2008-10-18 08:37:20 -------
(In reply to comment #4)
> (In reply to comment #2)
> > 1. какая видео карта?
> > 2. какой драйвер?
> > 3. еще где то это моделайн фигурирует?
> > 
> 
> Nvidia GeForce 440
> Драйвер именно тот, который система выбрала автоматически, я так понимаю -
> прориетарный nvidia, при загрузке X-сервера пролетает логотип. Моделайн не
> фигурирует больше нигде. Но если его убрать, то абсолютно ничего не
> изменится, пробовал! Хочется добавить следующее: на Debiane почему-то с проприетарным драйвером был выбор из двух частот - 60 Гц и 75 Гц. В Alt-е почему-то упорно предлагается две частоты, и тут варианты: Если в acc ставлю разрешение 1440х900 то 58 Гц и 61 Гц, но тогда разрешение тестовой картинки 1440х1024, если в acc ставлю разрешение "авто", то 50 Гц и 51 Гц. Хотя монитор по паспорту имеет 60 и 75 Гц. Странно?!
>