Bug 1759 - APT не поддерживает зависимости вида 'Requires(postun):' и удаляет пакеты в неверном порядке
: APT не поддерживает зависимости вида 'Requires(postun):' и удаляет пакеты в н...
Status: ASSIGNED
: Sisyphus
(All bugs in Sisyphus/apt)
: unstable
: all Linux
: P4 enhancement
Assigned To:
:
:
:
:
:
  Show dependency tree
 
Reported: 2002-12-25 23:26 by
Modified: 2010-10-09 18:38 (History)


Attachments
0001759-openoffice-dict-uk.spec (1.23 KB, application/octet-stream)
2002-12-25 23:26, Vyacheslav Dikonov
no flags Details


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2002-12-25 23:26:49
APT игнорирует строки типа 
Requires(pre,postun): foobar = %version-%release
в spec при задании очерёдности удаления пакетов. В результате, пакет, необходимый для выполнения скрипта %postun другого удаляемого вместе пакета, может быть удалён до отработки этого %postun.
---

---