Bug 17647 - Зависимости и библиотеки
: Зависимости и библиотеки
Status: CLOSED DUPLICATE of bug 16875
: Sisyphus
(All bugs in Sisyphus/gdal)
: unstable
: x86 Linux
: P2 normal
Assigned To:
:
:
:
:
:
  Show dependency tree
 
Reported: 2008-10-22 07:54 by
Modified: 2008-10-22 14:27 (History)


Attachments
spec для сборки gdal 1.5.2 (2.45 KB, text/plain)
2008-10-22 14:25, Sergey N. Yatskevich
no flags Details


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2008-10-22 07:54:15
Последний сизиф. Решил посмотреть пакет и вот что получилось:

[root@raflinux ~]# apt-get install gdal
Чтение списков пакетов... Завершено
Построение дерева зависимостей... Завершено
Следующие НОВЫЕ пакеты будут установлены:
  gdal
0 будет обновлено, 1 новых установлено, 0 пакетов будет удалено и 0 не
будет обновлено.
Необходимо получить 264kB архивов.
После распаковки потребуется дополнительно 1718kB дискового пространства.
Получено: 1 ftp://mirror.yandex.ru i586/classic gdal 1.4.0-alt1.1 [264kB]
Получено 264kB за 0s (310kB/s).
Совершаем изменения...
Preparing...                                    
###################################################################################################
[100%]
1: gdal                                         
###################################################################################################
[100%]
Завершено.
[root@raflinux ~]# gd
gdaladdo                  gdalinfo                 
gdaltindex                gdalwarp                 
gdal_contour              gdal_rasterize           
gdal_translate            gdk-pixbuf-query-loaders 
[root@raflinux ~]# gdalinfo
/usr/bin/gdalinfo: line 87: cd: /usr/src/RPM/BUILD/gdal-1.4.0/apps: Нет
такого файла или каталога
i586-alt-linux-g++: gdalinfo.o: Нет такого файла или каталога
i586-alt-linux-g++: /usr/src/RPM/BUILD/gdal-1.4.0/.libs/libgdal.so: Нет
такого файла или каталога
[root@raflinux ~]# apt-get install libgdal
Чтение списков пакетов... Завершено
Построение дерева зависимостей... Завершено
Следующие дополнительные пакеты будут установлены:
  libgeos
Следующие НОВЫЕ пакеты будут установлены:
  libgdal libgeos
0 будет обновлено, 2 новых установлено, 0 пакетов будет удалено и 0 не
будет обновлено.
Необходимо получить 1889kB архивов.
После распаковки потребуется дополнительно 5030kB дискового пространства.
Продолжить? [Y/n]
Получено: 1 ftp://mirror.yandex.ru i586/classic libgeos 2.2.3-alt1 [424kB]
Получено: 2 ftp://mirror.yandex.ru i586/classic libgdal 1.4.0-alt1.1
[1466kB]
Получено 1889kB за 2s (875kB/s). 
Совершаем изменения...
Preparing...                                    
###################################################################################################
[100%]
1: libgeos                                      
###################################################################################################
[ 50%]
2: libgdal                                      
###################################################################################################
[100%]
Завершено.
[root@raflinux ~]# gdalinfo
/usr/bin/gdalinfo: line 87: cd: /usr/src/RPM/BUILD/gdal-1.4.0/apps: Нет
такого файла или каталога
i586-alt-linux-g++: gdalinfo.o: Нет такого файла или каталога
i586-alt-linux-g++: /usr/src/RPM/BUILD/gdal-1.4.0/.libs/libgdal.so: Нет
такого файла или каталога

Откуда ноги растут?
------- Comment #1 From 2008-10-22 14:25:00 -------
Created an attachment (id=3011) [details]
spec для сборки gdal 1.5.2
------- Comment #2 From 2008-10-22 14:27:14 -------

*** This bug has been marked as a duplicate of bug 16875 ***