Bug 17657 - LucidaTypewriterRegular.ttf conflicts
: LucidaTypewriterRegular.ttf conflicts
Status: CLOSED FIXED
: Sisyphus
(All bugs in Sisyphus/fonts-ttf-java-1.6.0-sun)
: unstable
: all Linux
: P2 normal
Assigned To:
:
:
:
: 17674
:
  Show dependency tree
 
Reported: 2008-10-23 10:02 by
Modified: 2008-11-03 21:11 (History)


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2008-10-23 10:02:03
при сегодняшнем dist-upgrade получил

The following packages will be upgraded
  alterator-lilo emacs-git fonts-ttf-java-1.6.0-sun gcc-c++-common gcc-common
git git-arch git-core git-cvs git-doc
  git-email git-gui git-server git-svn gitk gitweb glibc glibc-core glibc-devel
glibc-gconv-modules glibc-locales glibc-nss
  glibc-preinstall glibc-timezones glibc-utils gutenprint gutenprint-foomatic
iconv java-1.6.0-sun java-1.6.0-sun-devel
  libgcc4.3 libgutenprint libqt3 libqt3-sqlite libqt4-core libqt4-dbus
libqt4-gui libqt4-network libqt4-xml libsasl2
  libstdc++4.3 perl-Git qt4-common tzdata
The following NEW packages will be installed:
  fonts-ttf-java-1.5.0-sun
44 upgraded, 1 newly installed, 0 removed and 0 not upgraded.
Need to get 0B/57.9MB of archives.
After unpacking 8540kB of additional disk space will be used.
Committing changes...
Preparing...                
########################################################################################
[100%]
file /usr/share/fonts/ttf/j2se-sun/LucidaTypewriterRegular.ttf conflicts
between attempted installs of fonts-ttf-java-1.5.0-sun-1.5.0.16-alt1 and
fonts-ttf-java-1.6.0-sun-1.6.0.10-alt1
E: Error while running transaction
------- Comment #1 From 2008-10-23 12:31:00 -------
и еще на всякий
rpm -qa | grep j2se
------- Comment #2 From 2008-10-23 12:56:08 -------
Ну то, что зачем-то вытягивается  fonts-ttf-java-1.5.0-sun - это бага отдельная
от непроставленного конфликта, мне кажется.
------- Comment #3 From 2008-10-23 17:52:57 -------
[az@az ~]$ rpm -qa | grep j2se
[az@az ~]$

зеро, так сказать...
------- Comment #4 From 2008-10-24 20:37:08 -------
подождем, что скажут по поводу
https://bugzilla.altlinux.org/show_bug.cgi?id=17674
------- Comment #5 From 2008-10-26 00:49:05 -------
java перезалил (alt2.1)
------- Comment #6 From 2008-10-26 12:25:51 -------
$ sudo apt-get dist-upgrade
Следующие пакеты будут ОБНОВЛЕНЫ:
  fonts-ttf-java-1.6.0-sun graphviz libgraphviz
Следующие пакеты будут УДАЛЕНЫ:
  KoLmafia java-1.6.0-sun java-1.6.0-sun-devel mozilla-plugin-java-1.6.0-sun
openoffice.org openoffice.org-kde openoffice.org-langpack-ru
  vuze
Следующие НОВЫЕ пакеты будут установлены:
  java-1.6.0-openjdk java-1.6.0-openjdk-devel tzdata-java

$ sudo apt-get install java-1.6.0-sun java-1.6.0-sun-devel
fonts-ttf-java-1.6.0-sun mozilla-plugin-java-1.6.0-sun
Чтение списков пакетов... Завершено
Построение дерева зависимостей... Завершено
Последняя версия java-1.6.0-sun уже установлена.
Последняя версия java-1.6.0-sun-devel уже установлена.
Последняя версия mozilla-plugin-java-1.6.0-sun уже установлена.
Некоторые пакеты установить невозможно. Это может означать, что Вы
потребовали невозможного, либо пользуетесь нестабильным репозиторием.
Часть необходимых пакетов либо ещё не создана, либо была удалена
из каталога 'Входящие'.
Эти сведения могут помочь найти выход из ситуации:

Следующие пакеты имеют неудовлетворенные зависимости:
  java-1.6.0-sun: Требует: /usr/share/fonts/ttf/j2se-sun
                  Требует: /usr/share/fonts/ttf/j2se-sun-oblique
E: Извините, `битые' пакеты

$ sudo apt-get install /usr/share/fonts/ttf/j2se-sun
Чтение списков пакетов... Завершено
Построение дерева зависимостей... Завершено
Виртуальный пакет /usr/share/fonts/ttf/j2se-sun предоставляется следующими
пакетами:
  fonts-ttf-java-1.6.0-sun 1.6.0.10-alt2 [Установлено]
  fonts-ttf-java-1.5.0-sun 1.5.0.16-alt1
  fonts-ttf-java-1.4.2-sun 1.4.2.17-alt1
Необходимо точно указать, какой из пакетов должен быть установлен.
E: Виртуальный пакет /usr/share/fonts/ttf/j2se-sun предоставляется многими
пакетами.

$ sudo apt-get install fonts-ttf-java-1.6.0-sun
Чтение списков пакетов... Завершено
Построение дерева зависимостей... Завершено
Следующие дополнительные пакеты будут установлены:
  java-1.6.0-openjdk java-1.6.0-openjdk-devel tzdata-java
Следующие пакеты будут ОБНОВЛЕНЫ:
  fonts-ttf-java-1.6.0-sun
Следующие пакеты будут УДАЛЕНЫ:
  KoLmafia java-1.6.0-sun java-1.6.0-sun-devel mozilla-plugin-java-1.6.0-sun
openoffice.org openoffice.org-kde openoffice.org-langpack-ru
  vuze
Следующие НОВЫЕ пакеты будут установлены:
  java-1.6.0-openjdk java-1.6.0-openjdk-devel tzdata-java
------- Comment #7 From 2008-10-26 12:58:27 -------
Напомню, 
Все беды от BuildArch: noarch в fonts-ttf-java-1.6.0-sun.
Если я эту строчку уберу, то все будет ok, но
это плохо, надо за BuildArch: noarch побороться.

Пока в сборках alt2* добавлен явный Obsoletes:
$ rpmquery -p --obsoletes fonts-ttf-java-1.6.0-sun-1.6.0.10-alt2.noarch.rpm 
[...]
fonts-ttf-java-1.4.2-sun  
fonts-ttf-java-1.5.0-sun  

Не помогло, apt все равно плющит.
Я по этому поводу повесил баг на apt.
см. также
https://bugzilla.altlinux.org/show_bug.cgi?id=17674#c8
------- Comment #8 From 2008-10-31 21:21:05 -------
should be fixed in alt2.2