Bug 1767 - garbage output on service internet {start,stop}
: garbage output on service internet {start,stop}
Status: CLOSED FIXED
: Sisyphus
(All bugs in Sisyphus/initscripts)
: unstable
: all Linux
: P5 normal
Assigned To:
:
:
:
:
:
  Show dependency tree
 
Reported: 2002-12-27 13:43 by
Modified: 2003-08-25 15:18 (History)


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2002-12-27 13:43:32
# service internet start
Checking internet connections to start at boot tput: invalid option -- 8
usage: tput [-V] [-S] [-T term] capname
[  OK  ]

This error also happens at boot and shutdown time.

strace shows:
execve(\"/bin/tput\", [\"tput\", \"hpa\", \"-8\"], ...

/etc/rc.d/init.d/internet is not owned by any package - apparently it was created by the ALT Linux Master 2.0 installer.
---

---

------- Comment #1 From 2002-12-27 13:53:47 -------
/etc/rc.d/init.d/internet shouldn\'t be created.
------- Comment #2 From 2002-12-27 13:53:47 -------
/etc/rc.d/init.d/internet shouldn\'t be created.
------- Comment #3 From 2002-12-27 14:36:09 -------
In fact, the problem is not specific to /etc/rc.d/init.d/internet - the same
error happens when the output is redirected to a pipe:

# service autofs restart 2>&1|cat 
Stopping automounter: tput: invalid option -- 8
usage: tput [-V] [-S] [-T term] capname
[  OK  ]
Starting automounter: tput: invalid option -- 8
usage: tput [-V] [-S] [-T term] capname
[  OK  ]
------- Comment #4 From 2002-12-27 14:36:09 -------
In fact, the problem is not specific to /etc/rc.d/init.d/internet - the same
error happens when the output is redirected to a pipe:

# service autofs restart 2>&1|cat 
Stopping automounter: tput: invalid option -- 8
usage: tput [-V] [-S] [-T term] capname
[  OK  ]
Starting automounter: tput: invalid option -- 8
usage: tput [-V] [-S] [-T term] capname
[  OK  ]
------- Comment #5 From 2002-12-28 02:30:55 -------
There is a bug in MOVE_TO_COL() function in /etc/rc.d/init.d/outformat;
Fixed in upcoming initscripts package.
------- Comment #6 From 2002-12-28 02:30:55 -------
There is a bug in MOVE_TO_COL() function in /etc/rc.d/init.d/outformat;
Fixed in upcoming initscripts package.