Bug 17820 - Падает python.req.py
: Падает python.req.py
Status: CLOSED DUPLICATE of bug 17154
: Sisyphus
(All bugs in Sisyphus/rpm-build-python)
: unstable
: all Linux
: P2 normal
Assigned To:
:
:
:
:
:
  Show dependency tree
 
Reported: 2008-11-08 14:34 by
Modified: 2008-11-08 14:45 (History)


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2008-11-08 14:34:45
При попытке создать пакет python.req.py падает с backtrace:

/usr/lib/rpm/python.req.py:
/home/rlz/tmp/Tartarus-clients-core-buildroot/usr/share/Tartarus/ClientsCore/Tartarus/common/ice.py:
line=44 IGNORE module=Tartarus
Traceback (most recent call last):
  File "/usr/lib/rpm/python.req.py", line 206, in <module>
    for item in match(lis) :
  File "/usr/lib/rpm/python.req.py", line 99, in match
    for item in match(node,deep) :
  File "/usr/lib/rpm/python.req.py", line 99, in match
    for item in match(node,deep) :
  File "/usr/lib/rpm/python.req.py", line 99, in match
    for item in match(node,deep) :
  File "/usr/lib/rpm/python.req.py", line 88, in match
    deps.append(node[2][1][1])
IndexError: string index out of range
------- Comment #1 From 2008-11-08 14:41:43 -------
Выяснил, что падает если в файле есть относительный импорт:

from ..<module> import ...
------- Comment #2 From 2008-11-08 14:45:27 -------

*** This bug has been marked as a duplicate of bug 17154 ***