Bug 17995 - Не работает вновь добавленный принтер
: Не работает вновь добавленный принтер
Status: CLOSED FIXED
: ALT Linux Desktop
(All bugs in ALT Linux Desktop/bugs)
: 4.1.0
: x86 Linux
: P2 normal
Assigned To:
:
:
:
:
:
  Show dependency tree
 
Reported: 2008-11-26 02:55 by
Modified: 2008-11-28 21:14 (History)


Attachments
hp.ppd (5.35 KB, text/plain)
2008-11-27 00:09, Jurij Bogaevskiy
no flags Details


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2008-11-26 02:55:19
На версии 1.3.9 устанавливаемый принтер не работает. Принтер HP DeskJet F2280.
Установка проводилась с установленным hplip и без него. Задание на печать
уходит, но принтер не печатает.
------- Comment #1 From 2008-11-26 10:16:22 -------
деталей мало.
что лежит в /etc/cups/ppd,
какой /etc/printers.conf,
версии пакетов, итд?
------- Comment #2 From 2008-11-26 21:02:16 -------
[root@localhost cups]# rpm -qa | grep cups
ghostscript-cups-8.62-alt0.M41.1
libcups-devel-1.3.9-alt0.M41.1
docs-print_cups-0.1-alt2
libcups-1.3.9-alt0.M41.1
cups-1.3.9-alt0.M41.1
libgnomecups-0.2.3-alt1

В /etc/cups/ppd - ничего нет.

/etc/printers.conf тоже пустой, старый вот
[root@localhost cups]# cat printers.conf.O
# Printer configuration file for CUPS v1.3.9
# Written by cupsd on 2008-11-21 01:19
<Printer tmpprinter_kAwFzEla>
Info
Location
DeviceURI usb://HP/Deskjet%20F2200%20series?serial=CN83J4T2BN0534
State Idle
StateTime 1227223197
Accepting Yes
Shared Yes
JobSheets none none
QuotaPeriod 0
PageLimit 0
KLimit 0
OpPolicy default
ErrorPolicy stop-printer
</Printer>

На версии cups из ALD 4.1 устанавливался этот МФУ без проблем (работал конечно
только принтер).
Пробовал сносить cups, чистить все конфиги и устанавливать с нуля - результат
тот же. Устанавливал hplip из Сизифа - на нем работает только сканер. hplip в
данный момент не установлен. С установленныйм hplip 2.7.12 и текущим cups - не
работает ничего. Проблема появилась после обновления из updates и удаления
принтера. Установить принтер после этого возможно, но он не работает.
------- Comment #3 From 2008-11-26 21:09:40 -------
раз /etc/cups/ppd пустой, то принтер не настроен.
Начните с того, чтобы добавить принтер в систему.
------- Comment #4 From 2008-11-26 23:10:13 -------
(In reply to comment #3)
Добавил принтер, при установке выбрал драйвер hp deskjet (оптимальный)

в /etc/cups/ppd/ теперь hp.ppd
------- Comment #5 From 2008-11-26 23:40:11 -------
ну и?
1) печатает? не печатает? что не работает?
2) приложите ppd

Юрий, я чувствую себя сотрудником гестапо,
допрашивающим упорного партизана :)
------- Comment #6 From 2008-11-26 23:44:53 -------
и еще версии hplip,
foomatic
------- Comment #7 From 2008-11-26 23:45:35 -------
как именно добавили принтер?
------- Comment #8 From 2008-11-27 00:06:38 -------
Не печатает. Принтер добавил через Параметры - принтеры - добавить принтер. 
# rpm -qa | grep foomatic
foomatic-db-engine-3.0.2-alt4
foomatic-3.0.1-alt2.20040828
gutenprint-foomatic-5.2.1-alt1.M41.1
foomatic-db-3.0.2-alt6.20080326
foomatic-filters-3.0.2-alt5

HPLIP не установлен, но пробовал и при установленном, версии 2.7.12 и
добавлении принтера с его помощью - результат тот же. На hplip из Сизифа -
заработал сканер, но принтер ни в какую. Раньше (до обновления) принтер работал
безо всяких hplip. (принтер HP DeskJet F2280, МФУ). 
Это моя первая бага, так что уж извините...
------- Comment #9 From 2008-11-27 00:09:38 -------
Created an attachment (id=3095) [details]
hp.ppd
------- Comment #10 From 2008-11-27 00:13:47 -------
вижу. ppd явно не к вашей модели :)
не удивительно.
------- Comment #11 From 2008-11-27 00:18:06 -------
вам надо ppd для 
deskjet_f2200_series
в Сизифе есть:
hp-deskjet_f2200_series-hpijs.ppd
вам нужно похоже свежий hplip поставить
------- Comment #12 From 2008-11-27 00:20:10 -------
Раньше (до обновления) принтер работал безо всяких hplip.
(принтер HP DeskJet F2280, МФУ).

он работал через hpijs, 
который часть hplip
весь hplip не обязательно, но часть поставить нужно.
------- Comment #13 From 2008-11-27 00:24:44 -------
т.е. для вас hplip 2.7.12 слишком старый. 
вам надо попробовать 2.8.x
------- Comment #14 From 2008-11-27 00:28:06 -------
и выбрать правильно модель принтера
------- Comment #15 From 2008-11-27 00:35:00 -------
Я ставил hplip из Сизифа и выбирал модель принтера, как Вы написали, но на нем,
как я уже писал, не работает принтер, а только сканер.
------- Comment #16 From 2008-11-27 10:55:41 -------
вот это мне и нужно.
только детально!
ставите новый hplip (указываете версии пакетов и откуда взяли/ как собирали)
и какой выбрали новый ppd (приложите)
и будем разбираться, почему не работает.

Старый не обязан работать c вашей моделью :)
------- Comment #17 From 2008-11-28 01:12:22 -------
rpm -qa | grep hplip
hplip-2.8.9-alt1
hplip-PPDs-2.8.9-alt1
hplip-hpijs-2.8.9-alt1
hplip-gui-2.8.9-alt1
hplip-common-2.8.9-alt1
hplip-sane-2.8.9-alt1

Брал из
ftp://ftp.altlinux.org/pub/distributions/ALTLinux/Sisyphus/i586/RPMS.classic/

Не пересобирал, так как встал без проблем.
При добавлении принтера выбрал hp-deskjet_f2200_series-hpijs.ppd.gz
Принтер установился, статус idle, при установке галку из тестовой страницы не
снимал. Страница не напечатана, задание висит с вот таким логом:
I [28/Nov/2008:00:09:16 +0200] [Job 137] Adding start banner page "none".
I [28/Nov/2008:00:09:16 +0200] [Job 137] Adding end banner page "none".
I [28/Nov/2008:00:09:16 +0200] [Job 137] File of type application/postscript
queued by "root".
I [28/Nov/2008:00:09:16 +0200] [Job 137] Queued on "Deskjet_F2200" by "root".
I [28/Nov/2008:00:09:16 +0200] [Job 137] Started filter
/usr/lib/cups/filter/pstops (PID 7822)
I [28/Nov/2008:00:09:16 +0200] [Job 137] Started filter
/usr/lib/cups/filter/foomatic-rip (PID 7823)
I [28/Nov/2008:00:09:16 +0200] [Job 137] Started backend
/usr/lib/cups/backend/hp (PID 7824)
E [28/Nov/2008:00:09:18 +0200] PID 7823 (/usr/lib/cups/filter/foomatic-rip)
stopped with status 3!
I [28/Nov/2008:00:09:18 +0200] Hint: Try setting the LogLevel to "debug" to
find out more.
E [28/Nov/2008:00:09:18 +0200] [Job 137] Job stopped due to filter errors.
------- Comment #18 From 2008-11-28 01:51:18 -------
сканер работает
------- Comment #19 From 2008-11-28 01:55:26 -------
спасибо! теперь хороший отчет.
Но забыли указать
rpm -qa | grep foomatic
------- Comment #20 From 2008-11-28 01:56:19 -------
сорри, торможу
------- Comment #21 From 2008-11-28 01:58:36 -------
обновите, пожалуйста, 
foomatic-filters до 3.0.2-alt6
* Thu Jun 05 2008 Igor Vlasenko <viy@altlinux.ru> 3.0.2-alt6
- 20080605

Теперь похоже понятно где ошибка - в hpijs должна быть
зависимость на foomatic-filters >= 3.0.2-alt6.

Проверьте пожалуйста и сообщите.
------- Comment #22 From 2008-11-28 02:42:14 -------
Таки работает!!! 

rpm -qa | grep foomatic
foomatic-db-engine-3.0.2-alt4
foomatic-3.0.1-alt2.20040828
gutenprint-foomatic-5.2.1-alt1.M41.1
foomatic-db-3.0.2-alt6.20080326
foomatic-filters-3.0.2-alt6

И принтер и сканер. Правда пробная страница из hplip получилась только в синем
цвете. Из ООо печатал текст - нормальный, черный. Завтра попробую еще в цвете
напечатать. Вернее уже сегодня :).
------- Comment #23 From 2008-11-28 13:59:23 -------
замечательно. 

заодно научились и правильно баги вешать :)
Партизанить при вешании багов плохо.
Чем меньше вы расскажете, тем труднее понять, что у вас происходит.

И гестаповские допросы устраивать тоже занятие не из приятных.
Считайте, что в этот раз вам повезло с хорошим гестапо :)
------- Comment #24 From 2008-11-28 20:09:18 -------
Напечатал еще раз по пробной странице из cups-a и из hplip. Все ок.
Спасибо за понимание насчет партизанщины. Я знаю, что нужно как можно больше
информации и желательно исчерпывающей, вот только не всегда знаю какую именно
информацию нужно предоставить.

Бум старацца.
------- Comment #25 From 2008-11-28 21:14:46 -------
Heil Stollman!