Bug 18040 - W: В Вашей системе установлено несколько версий пакета "cpp4.3".
: W: В Вашей системе установлено несколько версий пакета "cpp4.3".
Status: CLOSED NOTABUG
: Sisyphus
(All bugs in Sisyphus/cpp4.3)
: unstable
: all Linux
: P2 blocker
Assigned To:
:
:
:
:
:
  Show dependency tree
 
Reported: 2008-11-29 01:01 by
Modified: 2008-11-29 01:28 (History)


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2008-11-29 01:01:00
[root@localhost ~]# apt-get --yes update
Получено: 1 ftp://ftp.altlinux.org i586 release [745B]
Получено: 2 ftp://ftp.altlinux.org noarch release [743B]
Получено 1488B за 0s (1783B/s).
Получено: 1 ftp://ftp.altlinux.org i586/classic pkglist [2709kB]
Найдено ftp://ftp.altlinux.org i586/classic release
Получено: 2 ftp://ftp.altlinux.org noarch/classic pkglist [1348kB]
Найдено ftp://ftp.altlinux.org noarch/classic release
Получено 4057kB за 7s (532kB/s).
Чтение списков пакетов... Завершено
Построение дерева зависимостей... Завершено
W: В Вашей системе установлено несколько версий пакета "cpp4.3".

Этот пакет не может быть обновлён обычным путём до тех пор, пока Вы не
оставите только одну его версию. Чтобы оставить установленными несколько
версий,
и не пол
W: Возможно, Вам потребуется запустить `apt-get update' для исправления.
[root@localhost ~]# date
Сбт Ноя 29 00:58:17 MSK 2008
[root@localhost ~]#
------- Comment #1 From 2008-11-29 01:09:22 -------
Удалите лишнее.
------- Comment #2 From 2008-11-29 01:18:24 -------
(In reply to comment #1)
> Удалите лишнее.
> 

Лишнее что?
------- Comment #3 From 2008-11-29 01:22:22 -------
(In reply to comment #2)
> (In reply to comment #1)
> > Удалите лишнее.
> 
> Лишнее что?

В вашей системе образовалась лишняя версия пакета cpp4.3, см.
rpmquery -a cpp4.3

Её и удалите, напр.
rpmi -e cpp4.3-4.3.2-alt5
------- Comment #4 From 2008-11-29 01:28:14 -------
(In reply to comment #3)
> (In reply to comment #2)
> > (In reply to comment #1)
> > > Удалите лишнее.
> > 
> > Лишнее что?
> 
> В вашей системе образовалась лишняя версия пакета cpp4.3, см.
> rpmquery -a cpp4.3
> 
> Её и удалите, напр.
> rpmi -e cpp4.3-4.3.2-alt5
> 

[root@localhost ~]# rpmi -e cpp4.3-4.3.2-alt5
ошибка: удаление этих пакетов нарушит зависимости:
        cpp4.3 = 4.3.2-alt5 нужен для gcc4.3-4.3.2-alt5

После 
[root@localhost ~]# rpmi -e cpp4.3-4.3.2-alt4
всё вроде пошло