Bug 19019 - При использвании kppp и COM-модема на ttyS0 сбоит мышь
: При использвании kppp и COM-модема на ttyS0 сбоит мышь
Status: CLOSED FIXED
: ALT Linux Desktop
(All bugs in ALT Linux Desktop/bugs)
: 4.1.1
: x86 Linux
: P2 major
Assigned To:
:
:
:
:
:
  Show dependency tree
 
Reported: 2009-02-27 20:42 by
Modified: 2009-03-13 00:28 (History)


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2009-02-27 20:42:31
Вобщем проблема обнаружена только на дистрибутиве
"altlinux-4.1.0-desktop-i586-install-dvd5.iso". На
altlinux-4.0.3-desktop-i586-install_ru-dvd5.iso все работает прекрасно! 
При иcпользовании любого (любого производителя) модема, подключенного к
COM-порту (в ОС определяется на ttyS0). При настройке диалап соединения через
kppp, при опросе модема или установке соединения, вобщем при посылке команд на
порт, курсор мыши начинает "сходить с ума" - начинает беспорядочно перемещяться
по рабочему столу, открывать всплывающие меню правой кнопки мыши, а после
остановки курсора перестают работать кнопки мыши (мышь как USB так и PS/2 -
результат один и тот же). Помогает либо ресет либо отключение питания... 
Версия kppp не обновлялась. Все компоненты системы по умолчанию из указанного
дистрибутива, при установке выбирал все пункты устанавливаемого программного
обеспечения.
------- Comment #1 From 2009-03-03 13:16:07 -------
вероятнее всего, в /etc/X11/xorg.conf прописана мышь на порту /dev/ttyS0
------- Comment #2 From 2009-03-05 13:51:24 -------
(В ответ на комментарий №1)
> вероятнее всего, в /etc/X11/xorg.conf прописана мышь на порту /dev/ttyS0

Да, действительно, данный момент имеет место быть
---------------------------------------------------
Section "InputDevice"
    Identifier  "/dev/ttyS1"
    Driver      "mouse"
    Option        "Device" "/dev/ttyS1"
    Option        "Protocol" "microsoft"
EndSection

Section "InputDevice"
    Identifier  "/dev/ttyS0"
    Driver      "mouse"
    Option        "Device" "/dev/ttyS0"
    Option        "Protocol" "microsoft"
EndSection 
--------------------------------------------------------
Подскажите, пожалуйста, как исправить ситуацию? Я человек начинающий в Линух,
поэтому прошу по командам опишите, пожалуйста.
Заранее спасибо :)
------- Comment #3 From 2009-03-05 18:44:14 -------
> Подскажите, пожалуйста, как исправить ситуацию? Я человек начинающий в Линух,
> поэтому прошу по командам опишите, пожалуйста.
любым текстовым редактором от пользователя root удалите процитированные вами
строки.
------- Comment #4 From 2009-03-10 13:46:14 -------
(В ответ на комментарий №3)
> > Подскажите, пожалуйста, как исправить ситуацию? Я человек начинающий в Линух,
> > поэтому прошу по командам опишите, пожалуйста.
> любым текстовым редактором от пользователя root удалите процитированные вами
> строки.

После удаления строк, после перезагрузки, ОС грузится под командной строкой.
После восстановления файла xorg.conf - опять графически под иксами.
Опять прошу помощи :)
------- Comment #5 From 2009-03-10 13:48:08 -------
Да, пробовал менять ttySx на ttyS2 и ttyS3, ситуация та же - загрузка в
командной строке.
------- Comment #6 From 2009-03-10 16:51:29 -------
на всякий случай выкладываю весь xorg.conf
# With libXiconfig we don't need configuration for
# ps and usb mice.
# For serial mice we will set up all serial devices.
#
# Composite is not yet stable on even major drivers;
# uncomment to enable
#Section "Extensions"
#    Option      "RENDER" "Enable"
#    Option      "Composite" "Enable"
#EndSection

Section "ServerLayout"
    Identifier     "Minimal layout"
    Screen         "Screen0" 0 0
    InputDevice    "/dev/ttyS0" "CorePointer"
EndSection

Section "Module"
    Load  "freetype"
    Load  "glx"
    Load  "dri"
    Load  "dbe"
    SubSection "extmod"
        Option        "omit xfree86-dga"
    EndSubSection
EndSection

Section "ServerFlags"
    Option        "AutoAddDevices" "true"
    Option        "AllowMouseOpenFail" "true"
    Option        "AIGLX" "true"
EndSection

Section "InputDevice"
    Identifier  "/dev/ttyS1"
    Driver      "mouse"
    Option        "Device" "/dev/ttyS1"
    Option        "Protocol" "microsoft"
EndSection

Section "InputDevice"
    Identifier  "/dev/ttyS0"
    Driver      "mouse"
    Option        "Device" "/dev/ttyS0"
    Option        "Protocol" "microsoft"
EndSection

Section "Monitor"
    Identifier   "Monitor0|0"
EndSection

Section "Device"
    Identifier  "Card0|0"
    Driver      "intel"
EndSection

Section "Screen"
    Identifier "Screen0"
    Device     "Card0|0"
    Monitor    "Monitor0|0"
    DefaultDepth     16
    SubSection "Display"
        Depth     8
        Modes    "1280x1024" "1280x960" "1280x854" "1280x800" "1280x768"
"1280x720" "1152x870" "1152x864" "1120x840" "1024x768" "1024x736" "1024x600"
"960x720" "848x480" "832x624" "800x600" "720x576" "640x480"
    EndSubSection
    SubSection "Display"
        Depth     15
        Modes    "1280x1024" "1280x960" "1280x854" "1280x800" "1280x768"
"1280x720" "1152x870" "1152x864" "1120x840" "1024x768" "1024x736" "1024x600"
"960x720" "848x480" "832x624" "800x600" "720x576" "640x480"
    EndSubSection
    SubSection "Display"
        Depth     16
        Modes    "1280x1024" "1280x960" "1280x854" "1280x800" "1280x768"
"1280x720" "1152x870" "1152x864" "1120x840" "1024x768" "1024x736" "1024x600"
"960x720" "848x480" "832x624" "800x600" "720x576" "640x480"
    EndSubSection
    SubSection "Display"
        Depth     24
        Modes    "1280x1024" "1280x960" "1280x854" "1280x800" "1280x768"
"1280x720" "1152x870" "1152x864" "1120x840" "1024x768" "1024x736" "1024x600"
"960x720" "848x480" "832x624" "800x600" "720x576" "640x480"
    EndSubSection
    SubSection "Display"
        Depth     32
        Modes    "1280x1024" "1280x960" "1280x854" "1280x800" "1280x768"
"1280x720" "1152x870" "1152x864" "1120x840" "1024x768" "1024x736" "1024x600"
"960x720" "848x480" "832x624" "800x600" "720x576" "640x480"
    EndSubSection
EndSection

Section "DRI"
    Group        "xgrp"
    Mode         0660
EndSection
------- Comment #7 From 2009-03-11 12:22:51 -------
(В ответ на комментарий №5)
> Да, пробовал менять ttySx на ttyS2 и ttyS3, ситуация та же - загрузка в
> командной строке.

Такое впечатление, что вы каким-то образом портите файл при внесении в него
любых изменений..

советую попросить помощи в community@, или на форуме повторив процесс удаления
и приложив /var/log/Xorg.*.log
------- Comment #8 From 2009-03-12 10:25:49 -------
Все, спасибо, на форуме помогли...
Проблема была решена путем изменения значения /dev/ttyS0 на /dev/input/mice в
секциях Section "InputDevice" и Section "ServerLayout". Вот код файла
xorg.conf, который работает:
# With libXiconfig we don't need configuration for
# ps and usb mice.
# For serial mice we will set up all serial devices.
#
# Composite is not yet stable on even major drivers;
# uncomment to enable
#Section "Extensions"
#    Option      "RENDER" "Enable"
#    Option      "Composite" "Enable"
#EndSection

Section "ServerLayout"
    Identifier     "Minimal layout"
    Screen         "Screen0" 0 0
    InputDevice    "/dev/input/mice" "CorePointer"
EndSection

Section "Module"
    Load  "freetype"
    Load  "glx"
    Load  "dri"
    Load  "dbe"
    SubSection "extmod"
        Option        "omit xfree86-dga"
    EndSubSection
EndSection

Section "ServerFlags"
    Option        "AutoAddDevices" "true"
    Option        "AllowMouseOpenFail" "true"
    Option        "AIGLX" "true"
EndSection

Section "InputDevice"
    Identifier  "/dev/input/mice"
    Driver      "mouse"
    Option        "Device" "/dev/input/mice"
    Option        "Protocol" "microsoft"
EndSection

Section "Monitor"
    Identifier   "Monitor0|0"
EndSection

Section "Device"
    Identifier  "Card0|0"
    Driver      "intel"
EndSection

Section "Screen"
    Identifier "Screen0"
    Device     "Card0|0"
    Monitor    "Monitor0|0"
    DefaultDepth     16
    SubSection "Display"
        Depth     8
        Modes    "1280x1024" "1280x960" "1280x854" "1280x800" "1280x768"
"1280x720" "1152x870" "1152x864" "1120x840" "1024x768" "1024x736" "1024x600"
"960x720" "848x480" "832x624" "800x600" "720x576" "640x480"
    EndSubSection
    SubSection "Display"
        Depth     15
        Modes    "1280x1024" "1280x960" "1280x854" "1280x800" "1280x768"
"1280x720" "1152x870" "1152x864" "1120x840" "1024x768" "1024x736" "1024x600"
"960x720" "848x480" "832x624" "800x600" "720x576" "640x480"
    EndSubSection
    SubSection "Display"
        Depth     16
        Modes    "1280x1024" "1280x960" "1280x854" "1280x800" "1280x768"
"1280x720" "1152x870" "1152x864" "1120x840" "1024x768" "1024x736" "1024x600"
"960x720" "848x480" "832x624" "800x600" "720x576" "640x480"
    EndSubSection
    SubSection "Display"
        Depth     24
        Modes    "1280x1024" "1280x960" "1280x854" "1280x800" "1280x768"
"1280x720" "1152x870" "1152x864" "1120x840" "1024x768" "1024x736" "1024x600"
"960x720" "848x480" "832x624" "800x600" "720x576" "640x480"
    EndSubSection
    SubSection "Display"
        Depth     32
        Modes    "1280x1024" "1280x960" "1280x854" "1280x800" "1280x768"
"1280x720" "1152x870" "1152x864" "1120x840" "1024x768" "1024x736" "1024x600"
"960x720" "848x480" "832x624" "800x600" "720x576" "640x480"
    EndSubSection
EndSection

Section "DRI"
    Group        "xgrp"
    Mode         0660
EndSection
------- Comment #9 From 2009-03-13 00:13:52 -------
(В ответ на комментарий №8)
> Проблема была решена путем изменения значения /dev/ttyS0 на /dev/input/mice в
> секциях Section "InputDevice" и Section "ServerLayout".

А при каких обстоятельствах установщик(?) делает такую подляну, цепляя мышь на
COM-порт?
------- Comment #10 From 2009-03-13 00:28:55 -------
(В ответ на комментарий №9)
> (В ответ на комментарий №8)
> > Проблема была решена путем изменения значения /dev/ttyS0 на /dev/input/mice в
> > секциях Section "InputDevice" и Section "ServerLayout".
> 
> А при каких обстоятельствах установщик(?) делает такую подляну, цепляя мышь на
> COM-порт?
Не понял вопроса...
Если имеется ввиду, что я отмечал при установке, то вся установка по умолчанию,
софт весь выбирал для установки, но ставил через KVM (D-Link DKVM-4K
переключатель между системниками).
Хотя и без него (DKVM-4K) пробовал установку, тот же результат...