Bug 19088 - Падение при закрытии внутреннего редактора по "Esc".
: Падение при закрытии внутреннего редактора по "Esc".
Status: CLOSED FIXED
: Branch 5.0
(All bugs in Branch 5.0/kde4-krusader)
: unspecified
: all Linux
: P2 normal
Assigned To:
:
:
:
:
:
  Show dependency tree
 
Reported: 2009-03-06 19:37 by
Modified: 2009-04-10 23:18 (History)


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2009-03-06 19:37:52
krusader 2.0.0-beta1
При закрытии внутреннего редактора по "Esc" происходит падение.
------- Comment #1 From 2009-03-06 22:31:26 -------
У меня не падает. Пришлите, пожалуйста трейс.
------- Comment #2 From 2009-03-09 11:23:33 -------
Из под KDE 3.5.10 и у меня не падает.
Падает из под KDE 4.2:
krusader(20350)/kdeui (kdelibs): No such XML file "krviewer.rc"          
krusader(20350)/kdeui (kdelibs): No such XML file "krviewer.rc"          
Calling appendChild() on a null node does nothing.                       
*** glibc detected *** /usr/lib/kde4bin/krusader: corrupted double-linked list:
0x0864e338 ***
======= Backtrace: =========                                                    
/lib/libc.so.6[0xb6da2d75]                                                      
/lib/libc.so.6[0xb6da3014]                                                      
/lib/libc.so.6[0xb6da4f35]                                                      
/lib/libc.so.6(__libc_malloc+0x96)[0xb6da6fe6]                                  
/usr/lib/libQtCore.so.4(_Z7qMallocj+0x1a)[0xb7e8fc12]                           
/usr/lib/libQtCore.so.4(_ZN10QByteArray6resizeEi+0x66)[0xb7e965e6]              
/usr/lib/libQtGui.so.4[0xb740fff8]                                              
/usr/lib/libQtGui.so.4(_ZN12QApplication15x11ProcessEventEP7_XEvent+0x328)[0xb73f6444] 
/usr/lib/libQtGui.so.4[0xb7411ff9]                                              
/usr/lib/libQtCore.so.4(_ZN10QEventLoop13processEventsE6QFlagsINS_17ProcessEventsFlagEE+0x54)[0xb7f259da]
/usr/lib/libQtCore.so.4(_ZN10QEventLoop4execE6QFlagsINS_17ProcessEventsFlagEE+0xef)[0xb7f25b79] 
/usr/lib/libQtCore.so.4(_ZN16QCoreApplication4execEv+0xb2)[0xb7f280e0]          
/usr/lib/libQtGui.so.4(_ZN12QApplication4execEv+0x24)[0xb73ac8d2]               
/usr/lib/kde4bin/krusader[0x8088171]                                            
/lib/libc.so.6(__libc_start_main+0xe5)[0xb6d4f925]                              
/usr/lib/kde4bin/krusader[0x8080e31]
------- Comment #3 From 2009-03-09 22:58:25 -------
Да,действительно, kde4-krusader падает. Так и надо тогда было вешать багу на
kde4-krusader, а не на krusader во избежание недопонимания. Это разные пакеты в
данный переходный момент, хоть у них и один мантейнер в моем лице. Попытаюсь
посмотреть, хотя, конечно, сыровата ещё пока 2.0.0. Недаром, что пока ещё не
релиз.
------- Comment #4 From 2009-03-09 23:10:14 -------
https://bugs.launchpad.net/ubuntu/+source/krusader/+bug/336324

Ссылка на launchpad - вдруг пофиксят раньше апстрима. В KDE, надо полагать бага
эта: https://bugs.kde.org/show_bug.cgi?id=184223
Своего багтрекера у krusader нет, раньше пользовались от sf, но он страшный,
как ядерная война и тормозной. Даже искать его не хочу.
------- Comment #5 From 2009-03-10 01:07:02 -------
Собрал новую версию из SVN - kde4-krusader-2.0.0-alt1.svn6244.1.i586.rpm
Проблема исчезла.
Как появится в Сизифе - жду сообщения от багрепортера.
------- Comment #6 From 2009-03-13 20:15:42 -------
Не падает.