Bug 19205 - проблемы при запуске. Виновата libopenal
: проблемы при запуске. Виновата libopenal
Status: CLOSED FIXED
: Sisyphus
(All bugs in Sisyphus/openal-soft)
: unstable
: all Linux
: P2 normal
Assigned To:
:
:
:
:
:
  Show dependency tree
 
Reported: 2009-03-16 20:52 by
Modified: 2009-04-26 17:43 (History)


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2009-03-16 20:52:47
Система была установлена 4.1.1
Затем до сизифа.

При запуске quake3 получаю ошибку:

------ Initializing Sound ------
/usr/lib/games/quake3/ioquake3.i386: symbol lookup error:
/usr/lib/games/quake3/ioquake3.i386: undefined symbol: alcIsExtensionPresent

оказалось, что в системе установлена libopenal0-1.5.304-alt1. При попытке
снести её сносится и quake3.
Выбрал для установки libopenal-0.0.9-alt1. И удалил openal0-1.5.304-alt1.
Игра заработала.

Наверное надо зависимости как-то поправить?
------- Comment #1 From 2009-03-16 21:11:57 -------
Это не баг quake3.

Это баг libopenal0, которая провайдит libopenal.so.0, но при этом не
обеспечивает какой-либо совместимости.

Перевешиваю на нее.
------- Comment #2 From 2009-03-17 08:05:44 -------
(В ответ на комментарий №1)
> Перевешиваю на нее.

Да, согласен.
------- Comment #3 From 2009-03-30 23:37:26 -------
Как я понимаю, проблема в том, что у libopenal апстрима нет, а псевдёж Creative
насчет того, что openal-sofrt его заменяет, неверен?
------- Comment #4 From 2009-04-17 15:53:16 -------
*** Bug 19644 has been marked as a duplicate of this bug. ***
------- Comment #5 From 2009-04-17 16:02:41 -------
Переименовал libopenal из этого пакета в libopenal0, от греха подальше