Bug 19252 - Не работает с новым FF
: Не работает с новым FF
Status: NEW
: Sisyphus
(All bugs in Sisyphus/firefox-settings-desktop)
: unstable
: all Linux
: P2 blocker
Assigned To:
:
:
:
:
:
  Show dependency tree
 
Reported: 2009-03-19 20:39 by
Modified: 2012-10-19 12:43 (History)


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2009-03-19 20:39:42
$ rpm -qa | grep firefox
firefox-3.1-alt1.20090312
firefox-uk-3.1-alt2
firefox-ru-3.1-alt2
firefox-settings-desktop-4.1.1-alt1

При заходе на https://localhost:8080/ вылезает ошибка SSL в виде netError, а не
certError, как везде анонсировалось.  Вылечилось после удаления
firefox-settings-desktop и _создания_ в about:config опции
"security.alternate_certificate_error_page" со значением "certerror".
------- Comment #1 From 2009-03-19 20:58:46 -------
Это всё делалось на новом профиле.
------- Comment #2 From 2009-03-19 21:00:53 -------
$ rpm -ql firefox | xargs grep security.alternate_certificate_error_page 
/etc/mozilla/firefox/default/defaults/preferences/firefox.js:pref("security.alternate_certificate_error_page",
"certerror");

Аналогичной настройки в firefox-settings-desktop не наблюдается.
------- Comment #3 From 2009-08-26 22:41:44 -------
сейчас (сизиф от 26 авг)

# rpm -ql firefox | xargs grep security.alternate_certificate_error_page
/etc/mozilla/firefox/default/defaults/preferences

дает

/firefox.js:pref("security.alternate_certificate_error_page", "certerror");

firefox-ru-3.5.1-alt1
firefox-3.5.1-alt1
firefox-uk-3.5.1-alt2
firefox-settings-desktop-5.0-alt2

исправлено?
(при заходе на https://localhost:8080/ показывается честная ошибка про
untrusted issuer, самоподписанный сертификат)
------- Comment #4 From 2011-02-22 20:16:13 -------
Доброго времени.
Бага еще актуальна?
------- Comment #5 From 2012-10-19 12:43:54 -------
Насколько понимаю, из firefox уже некоторое время как убрана поддержка внешних
пакетов settings и этот пакет следует убрать из сизифа.