Bug 1931 - apt-get is unable to handle gstream upgrade
: apt-get is unable to handle gstream upgrade
Status: CLOSED FIXED
: Sisyphus
(All bugs in Sisyphus/apt)
: unstable
: all Linux
: P2 blocker
Assigned To:
:
:
:
:
:
  Show dependency tree
 
Reported: 2003-01-14 11:15 by
Modified: 2003-08-25 15:18 (History)


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2003-01-14 11:15:03
apt-get is unable to handle upgrade from
gstreamer-0.5.0-alt1
to
gstreamer-0.5.1-alt1 and higher.

See also #0001840
---
# rpmquery -a |fgrep gstreamer
libgstreamer-0.5.0-alt1
gstreamer-0.5.0-alt1
# apt-get install gstreamer
[...]
Do you want to continue? [Y/n] y
E: Couldn\'t configure pre-depend gstreamer-utils for gstreamer, probably a dependency cycle.

---
# apt-get -o Debug::pkgProblemResolver=true -o Debug::pkgOrderList=true install gstreamer
Reading Package Lists...
Collecting File Provides...
Building Dependency Tree...
Starting
Starting 2
Done
The following extra packages will be installed:
  gstreamer-utils libgstreamer 
The following packages will be upgraded
  gstreamer libgstreamer 
The following NEW packages will be installed:
  gstreamer-utils 
** Pass A
Visit gstreamer
 Visit gstreamer-utils
  Visit libgstreamer
  Leave libgstreamer 1,0
 Leave gstreamer-utils 1,0
Leave gstreamer 1,0
** Pass B
Visit libgstreamer
 Visit gstreamer
  Visit gstreamer-utils
  Leave gstreamer-utils 1,0
 Leave gstreamer 1,0
Leave libgstreamer 1,0
** Pass C
Visit gstreamer-utils
Leave gstreamer-utils 1,0
Visit gstreamer
Leave gstreamer 1,0
Visit libgstreamer
Leave libgstreamer 1,0
** Pass D
Visit gstreamer-utils
Leave gstreamer-utils 1,0
Visit gstreamer
Leave gstreamer 1,0
Visit libgstreamer
Leave libgstreamer 1,0
** Unpack ordering done
gstreamer-utils 0,0
gstreamer 0,0
libgstreamer 0,0
2 packages upgraded, 1 newly installed, 0 removed and 4 not upgraded.
Need to get 0B/580kB of archives. After unpacking 21,5kB will be freed.
Do you want to continue? [Y/n] ** Pass A
Visit gstreamer
 Visit gstreamer-utils
  Visit libgstreamer
  Leave libgstreamer 1,0
 Leave gstreamer-utils 1,0
Leave gstreamer 1,0
** Pass B
Visit libgstreamer
 Visit gstreamer
  Visit gstreamer-utils
  Leave gstreamer-utils 1,0
 Leave gstreamer 1,0
Leave libgstreamer 1,0
** Pass C
Visit gstreamer-utils
Leave gstreamer-utils 1,0
Visit gstreamer
Leave gstreamer 1,0
Visit libgstreamer
Leave libgstreamer 1,0
** Pass D
Visit gstreamer-utils
Leave gstreamer-utils 1,0
Visit gstreamer
Leave gstreamer 1,0
Visit libgstreamer
Leave libgstreamer 1,0
** Unpack ordering done
gstreamer-utils 0,0
gstreamer 0,0
libgstreamer 0,0
E: Couldn\'t configure pre-depend gstreamer-utils for gstreamer, probably a dependency cycle.

------- Comment #1 From 2003-02-10 13:54:21 -------
Fixed in apt-0.5.5cnc1-alt1
------- Comment #2 From 2003-02-10 13:54:21 -------
Fixed in apt-0.5.5cnc1-alt1