Bug 19490 - Падает при попытке запуска интерактивного режима (Game)
: Падает при попытке запуска интерактивного режима (Game)
Status: CLOSED NOTABUG
: Branch 5.0
(All bugs in Branch 5.0/blender)
: unspecified
: all Linux
: P2 major
Assigned To:
:
:
:
:
:
  Show dependency tree
 
Reported: 2009-04-05 22:58 by
Modified: 2009-04-13 11:24 (History)


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2009-04-05 22:58:33
Воспроизводится стабильно, в том числе и на предыдущих версиях (ALD 4.1)
Запускаем blender жмем P или выбираем в меню Game->Start game и программа
падает. В консоль пишет:
/usr/bin/blender-bin: symbol lookup error: /usr/bin/blender-bin: undefined
symbol: alcOpenDevice
Статическая версия программки с апстрима работает на том же оборудовании в той
же системе корректно.
------- Comment #1 From 2009-04-11 04:19:53 -------
Хммм, у меня не падает. libopenal стоит?
------- Comment #2 From 2009-04-11 19:23:19 -------
> Хммм, у меня не падает. libopenal стоит?
Да, на 4.1.1 libopenal стоит, там сегфолт при попытке запуска game
/usr/bin/blender: line 58: 12188 Ошибка сегментирования                  
/usr/bin/blender-bin $@

Насчет 5.0beta отчитаюсь, но если падает из за отсутствия openAl, то нужно
поставить blender-у зависимость от этого пакета.
------- Comment #3 From 2009-04-13 08:08:08 -------
Похоже кривые руки. Работает.
------- Comment #4 From 2009-04-13 11:24:08 -------
В зависимостях blender в Сизифе есть и указание на libopenal.so.0. Зависимость
есть.