Bug 19602 - misleading message during upgrade
: misleading message during upgrade
Status: CLOSED FIXED
: Sisyphus
(All bugs in Sisyphus/apache-common)
: unstable
: all Linux
: P3 minor
Assigned To:
:
:
:
:
:
  Show dependency tree
 
Reported: 2009-04-13 16:13 by
Modified: 2009-05-22 17:31 (History)


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2009-04-13 16:13:54
apache-common-1.3.41rusPL30.23-alt6

При обновлении с apache-common-1.3.39rusPL30.23-alt2 было выдано сообщение:

Warning: User apache is not included in the group _webserver!
     Add user apache to group _webserver.

При взгляде на текст сообщения создаётся впечатление, что после установки
требуется вручную добавить пользователя apache в группу _webserver; однако на
самом деле это действие выполняется в %pre автоматически.

Видимо, сообщение должно выглядеть как-то так:

Warning: User apache was not included in the group _webserver!
     Added user apache to group _webserver.

(и вывод второй строки подвинуть после вызова gpasswd на случай ошибки).
------- Comment #1 From 2009-04-14 19:41:33 -------
Исправил так:
http://git.altlinux.org/people/solo/packages/?p=apache.git;a=commit;h=67d9ed60453c25b47854e7ae110326fcb9614bed

В Сезиф пока неотправляю -- дождусь болие значимых изменений.
------- Comment #2 From 2009-05-22 17:31:53 -------
apache-1.3.41rusPL30.23-alt7 -> sisyphus:

* Fri May 22 2009 Aleksey Avdeev <solo@altlinux> 1.3.41rusPL30.23-alt7

- Update message in %pre common (Closes: #19602)
  (thanks to Sergey Vlasov <vsu altlinux org>)
- mod_perl-doc: fix package install