Bug 19652 - strange deps
: strange deps
Status: CLOSED FIXED
: Sisyphus
(All bugs in Sisyphus/poppler)
: unstable
: all Linux
: P3 blocker
Assigned To:
:
:
:
:
:
  Show dependency tree
 
Reported: 2009-04-17 12:04 by
Modified: 2009-07-20 15:33 (History)


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2009-04-17 12:04:23
$ rpm -qp --provides poppler-0.10.5-alt1.i586.rpm 
xpdf-utils = 3.02-alt4
poppler = 0.10.5-alt1
$ rpm -qp --conflicts poppler-0.10.5-alt1.i586.rpm 
xpdf-utils  
xpdf-reader  
pdftohtml  

и как следствие:
$ hsh-install $TMPDIR poppler
error: failed dependencies:
        xpdf-utils conflicts with poppler-0.10.5-alt1

То есть пакет невозможно установить. А жаль придётся для cups использовать
xpdf-utils.
------- Comment #1 From 2009-04-17 14:25:06 -------
А чего странного?
В системе все ставиться.
Откуда там взялся xpdf-utils?
------- Comment #2 From 2009-04-17 16:29:48 -------
(В ответ на комментарий №1)
> А чего странного?
Пакет конфликтует с тем что сам и провайдит то есть сам с собой.
> В системе все ставиться.
А в хешере нет (см. пример ниже)
> Откуда там взялся xpdf-utils?
Он мне нужен чтобы во время сборки правильно отработал configure.
------- Comment #3 From 2009-07-20 15:33:56 -------
poppler-0.10.7-alt2, xpdf-3.02-alt6