Bug 20239 - не стартуют X'ы на hp6720s (GME965/GLE960) при обновлении до 2.6.29-std-def-alt2
: не стартуют X'ы на hp6720s (GME965/GLE960) при обновлении до 2.6.29-std-def-alt2
Status: CLOSED FIXED
: Sisyphus
(All bugs in Sisyphus/kernel-image-std-def)
: unstable
: all Linux
: P3 major
Assigned To:
:
:
:
:
: 19564
  Show dependency tree
 
Reported: 2009-05-30 22:14 by
Modified: 2009-06-17 20:48 (History)


Attachments
xsession-errors при старте KDE4 на i915 c ядром 2.6.29-std-def-alt(1|2) (2.28 KB, application/zip)
2009-06-06 17:41, PeterVF
no flags Details


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2009-05-30 22:14:36
#lspci | grep VGA
00:02.0 VGA compatible controller: Intel Corporation Mobile GME965/GLE960
Integrated Graphics Controller (rev 0c)

# rpm -qa | grep intel
xorg-dri-intel-7.5-alt1.rc2
xorg-drv-intel-2.7.1-alt1

#uname -a
Linux arc-laptop.localdomain 2.6.29-std-def-alt2 #1 SMP Thu May 28 17:35:35 UTC
2009 i686 GNU/Linux

....
(EE) intel(0): No modes.
(II) UnloadModule: "intel"
(EE) Screen(s) found, but none have a usable configuration.
....
полный лог:
http://forum.altlinux.org/index.php?action=dlattach;topic=3269.0;attach=1948

С ядром 2.6.27 иксы стартуют.
C 2.6.29 от лакостиса тоже работает.
Конфиг иксов правил, удалял ...
На 2.6.29 из сизифа -- не работает 
Еще одно:
Как оказалось, если подцепить внешний монитор, то он подхватывается.
Свою панель ноутбук игнорирует
------- Comment #1 From 2009-06-01 10:56:30 -------
vga=normal?
------- Comment #2 From 2009-06-01 16:02:13 -------
На всякий случай уточняю: имелось в виду попробуйте загрузиться с параметором
ядра vga=normal
------- Comment #3 From 2009-06-02 11:12:50 -------
(В ответ на комментарий №1)
> vga=normal?
нет эффекта
------- Comment #4 From 2009-06-06 17:41:07 -------
Created an attachment (id=3590) [details]
xsession-errors при старте KDE4 на i915 c ядром 2.6.29-std-def-alt(1|2)

Похоже, моя проблема тоже в этой баге:
ставил altlinux-5.0.0_beta-20090528-desktop-i586-ru-install-dvd5.iso
на комп со встроеной i915
после ввода пароля плавно начинает грузиться KDE(4): сначала одна иконка, потом
еще три .. потом черный экран и снова прглашение.
При попытке startx  от root-а, комп повис (тоже при старте kde)
xsession-error от root-а прилагаю .
От юзера не сохранился, т.к. действительно, с ядром от лакостиса
http://www.unsafe.ru/lakostis/RPMS/ALTLinux/testing/repo/i586/RPMS.hasher/
"нормально" загрузился (спасибо за наводку).
На другом компе, тоже i915 при загрузке LiveCD с тогоже диска, впал в цикл тоже
при загрузке KDE. Цикл не бесконечный, через некоторое время комп наглухо
повис, а на экране рябь.
------- Comment #5 From 2009-06-07 18:29:01 -------
(В ответ на комментарий №3)
> (В ответ на комментарий №1)
> > vga=normal?
> нет эффекта

тогда в lilo.conf к .29 ядру
addappend=" i915.modeset=0"
------- Comment #6 From 2009-06-07 21:37:37 -------
(В ответ на комментарий №5)
> (В ответ на комментарий №3)
> > (В ответ на комментарий №1)
> > > vga=normal?
> > нет эффекта
> 
> тогда в lilo.conf к .29 ядру
> addappend=" i915.modeset=0"
есть
Однако при загрузке получил фриз. Воспроизвести фриз пока не удалось.
Как я понял баг локализован?
------- Comment #7 From 2009-06-07 22:55:12 -------
(In reply to comment #6)
> (В ответ на комментарий №5)
> > (В ответ на комментарий №3)
> > > (В ответ на комментарий №1)
> > > > vga=normal?
> > > нет эффекта
> > 
> > тогда в lilo.conf к .29 ядру
> > addappend=" i915.modeset=0"
> есть
> Однако при загрузке получил фриз. Воспроизвести фриз пока не удалось.

"Не удалось" -- значит в других загрузках все нормально?

> Как я понял баг локализован?
------- Comment #8 From 2009-06-07 22:59:12 -------
при горячем старте с .27 на .29 могут быть проблемы
------- Comment #9 From 2009-06-07 23:23:39 -------
(В ответ на комментарий №8)
> при горячем старте с .27 на .29 могут быть проблемы

Два часа -- полет нормальный.
Фриз был еще и при убиении  glxgears, запустил сразу после удачной загрузки.
До этого на .27 и .29 от лакостиса был рандомный фриз, предположительно на
эффектах. Завтра постараюсь воспроизвести.
------- Comment #10 From 2009-06-07 23:24:45 -------
> > Однако при загрузке получил фриз. Воспроизвести фриз пока не удалось.
> 
> "Не удалось" -- значит в других загрузках все нормально?
> 
пока да
------- Comment #11 From 2009-06-09 10:18:56 -------
(В ответ на комментарий №10)
> > > Однако при загрузке получил фриз. Воспроизвести фриз пока не удалось.
> > 
> > "Не удалось" -- значит в других загрузках все нормально?
> > 
> пока да

Фриз при разворачивании списка тем рабочего стола.
Есть мнение, что проблема возникает при активном использовании OpenGL(dri?), в
частности для отрисовки эффектов.
------- Comment #12 From 2009-06-11 07:23:39 -------
kernel-image-std-def-1:2.6.29-alt3 -> sisyphus:

* Sun Jun 07 2009 Michail Yakushin <silicium@altlinux> 1:2.6.29-alt3

- fix i915 support(shrek@) (closes #20239):
    +disable GEM on i8xx 
    +disable KMS by default
    +allow tiled front buffers on 965+
- add Usb-serial driver for Moxa NP1240/1220/1220I
- update aufs patch. Replaced by aufs-standalone (closes: #20344)
------- Comment #13 From 2009-06-17 20:48:28 -------
на ванильном самосборе 2.6.30 никаких фризов.