Bug 20388 - doesn't treat the pasted text from X correctly as text (word wrapping, fonts)
: doesn't treat the pasted text from X correctly as text (word wrapping, fonts)
Status: CLOSED WONTFIX
: Branch 4.1
(All bugs in Branch 4.1/emacs22-X11-gtk)
: unspecified
: all Linux
: P3 normal
Assigned To:
:
:
:
:
:
  Show dependency tree
 
Reported: 2009-06-09 16:01 by
Modified: 2014-11-05 20:42 (History)


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2009-06-09 16:01:02
emacs22-X11-gtk-22.2-alt5 in xorg-server-1.4.2-alt10.M41.1, Desktop 4.1

]$ locale
LANG=ru_RU.UTF-8
LC_CTYPE="ru_RU.UTF-8"
LC_NUMERIC="ru_RU.UTF-8"
LC_TIME="ru_RU.UTF-8"
LC_COLLATE="ru_RU.UTF-8"
LC_MONETARY="ru_RU.UTF-8"
LC_MESSAGES="ru_RU.UTF-8"
LC_PAPER="ru_RU.UTF-8"
LC_NAME="ru_RU.UTF-8"
LC_ADDRESS="ru_RU.UTF-8"
LC_TELEPHONE="ru_RU.UTF-8"
LC_MEASUREMENT="ru_RU.UTF-8"
LC_IDENTIFICATION="ru_RU.UTF-8"
LC_ALL=
$ 

How to reproduce:

start emacs in X, M-x text-mode, and paste a long Russian line from Firefox
into Emacs (by middle-clicking or through the clipboard -- it doesn't matter),
for example:

дивять десять одиннадцать двенадцать тринадцать четырнадцать пятнадцать
шестнадцать семнадцать восемнадцать девятнадцать двадцать

then press space.

Result: the long pasted line is wrapped, but at wrong places (inside words):

дивять десять одиннадцать двенадцать
тринадцать четырнадцать пятнадцать ш
естнадцать семнадцать восемнадцать д
евятнадцать двадцать 

If you type one more word in Russian (e.g., "дивять"), you'll see that the
fonts for the pasted text and normally entered text are different. (It's ugly
for the pasted text.)

Then, M-x ispell-change-dictionary russian, M-x flyspell-buffer, and you'll see
that the misspelt "дивять" in the pasted text is not detected, but the one
entered in the normal way is detected as misspelt.

Expected: pasted Russian text is treated correctly as text.

Workaround: save the buffer to file immediately after pasting, and re-open it.
------- Comment #1 From 2009-06-09 23:00:46 -------
Cannot reproduce this bug in clean emacs (started as "emacs -Q") or with
site-file (emacs -q). Please provide minimal test case (init file and installed
extensions) for reproduce bug.
------- Comment #2 From 2014-11-05 20:42:51 -------
В 4.1/branch исправления не будут вноситься уже технически (заглушена очередь
на сборку), поэтому прошу ошибки, актуальные для sisyphus/p7/t7, перевесить на
текущие ветки или сизиф.