Bug 20458 - Список стран пуст.
: Список стран пуст.
Status: CLOSED DUPLICATE of bug 22800
: Sisyphus
(All bugs in Sisyphus/alterator-datetime)
: unstable
: all Linux
: P3 minor
Assigned To:
:
:
:
:
:
  Show dependency tree
 
Reported: 2009-06-15 16:18 by
Modified: 2011-02-08 21:34 (History)


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2009-06-15 16:18:27
Если запустить acc непосредственно от рута,
тогда списки стран и часовых поясов пусты,
т.е. модуль получается работает только если выполняется в локали, отличной от
POSIX ?
------- Comment #1 From 2011-02-08 21:22:53 -------
Проблема в guile:

$ LC_ALL=C.UTF-8 dumpisotab
ERROR: In procedure setlocale:
ERROR: Invalid argument

http://git.altlinux.org/gears/a/alterator-datetime.git?p=alterator-datetime.git;a=blob;f=alterator-datetime/bin/alterator-datetime-functions;h=20f224609da3dd19b7f9016d5cd78283fe6a1a5d;hb=HEAD#l95


$ LC_ALL=C.UTF-8 guile -c '(setlocale LC_ALL "")'
ERROR: In procedure setlocale:
ERROR: Invalid argument

$ LC_ALL=C guile -c '(setlocale LC_ALL "")'
$
------- Comment #2 From 2011-02-08 21:28:02 -------
*** Bug 21130 has been marked as a duplicate of this bug. ***
------- Comment #3 From 2011-02-08 21:34:15 -------
Дублирует ALT #22800

*** This bug has been marked as a duplicate of bug 22800 ***