Bug 20571 - Не работает с tcl/tk из бранча
: Не работает с tcl/tk из бранча
Status: CLOSED FIXED
: Sisyphus
(All bugs in Sisyphus/vtcl)
: unstable
: all Linux
: P3 normal
Assigned To:
:
:
:
:
:
  Show dependency tree
 
Reported: 2009-06-24 21:49 by
Modified: 2018-11-07 10:31 (History)


Attachments
Quick fix (375 bytes, patch)
2018-03-22 20:51, Vladimir D. Seleznev
no flags Details | Diff


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2009-06-24 21:49:16
Версия vtcl 1.6.0 в описании написано работает с Tcl/Tk начиная от 8.3.
В 5 бранче версия Tcl/Tk 8.5.5, при запуске vtcl ругается на версию

Error in startup script: version conflict for package "Tk": have 8.5.5, need
exactly 8.5
------- Comment #1 From 2018-03-21 17:36:17 -------
Пакет не обновлялся с 2003 года и ошибка присутствует до сих пор в сизифе.

$ vtcl
Error in startup script: version conflict for package "Tk": have 8.6.8, need
exactly 8.6
------- Comment #2 From 2018-03-22 20:51:11 -------
Created an attachment (id=7445) [details]
Quick fix
------- Comment #3 From 2018-10-29 19:47:40 -------
vtcl-1.6.1a1-alt1 -> sisyphus:

Mon Oct 29 2018 Grigory Ustinov <grenka@altlinux> 1.6.1a1-alt1
- Build new version.
- Add patch for tk version (Closes: #20571).
- Add patch for browser.
- Change license and cleanup spec.
------- Comment #4 From 2018-11-07 10:31:04 -------
(In reply to comment #3)
> - Change license and cleanup spec.

Это всё-таки не Change, а fix, но на самом деле уточнение.

Эта строчка [1] из другой записи ченджлога приехала.

Если применяется такой патч [2], то /usr/bin/xdg-open следует записать в
Requires пакета с указанием комментария на патч.

[1] 
http://git.altlinux.org/srpms/v/vtcl.git?p=vtcl.git;a=blob;f=vtcl.spec;h=d87c351872b2ef872a82ea051b408cacafc6f9e2;hb=59f99bfea2e8a55240113275b1d4b9f927897886#l57
[2]
http://git.altlinux.org/srpms/v/vtcl.git?p=vtcl.git;a=blob;f=vtcl-browser.patch;h=a6b57c3812e1bfb2cfc2ef8b8fdf584f34bf15da;hb=59f99bfea2e8a55240113275b1d4b9f927897886