Bug 20817 - file /usr/lib/libfxscintilla.so from install of libfxscintilla-devel-1.78.0-alt1 conflicts
: file /usr/lib/libfxscintilla.so from install of libfxscintilla-devel-1.78.0-a...
Status: CLOSED WONTFIX
: Sisyphus
(All bugs in Sisyphus/libfox)
: unstable
: all Linux
: P3 normal
Assigned To:
:
:
:
:
:
  Show dependency tree
 
Reported: 2009-07-18 00:26 by
Modified: 2012-03-16 14:00 (History)


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2009-07-18 00:26:19
# apt-get install libfxscintilla-devel
Reading Package Lists... Done
Building Dependency Tree... Done
The following extra packages will be installed:
  libfxscintilla20
The following packages will be upgraded
  libfxscintilla-devel
The following NEW packages will be installed:
  libfxscintilla20
...
file /usr/lib/libfxscintilla.so from install of
libfxscintilla-devel-1.78.0-alt1 conflicts with file from package
libfxscintilla-1.63-alt4
------- Comment #1 From 2009-07-18 00:54:43 -------
Пакет libfxscintilla-1.63-alt4 вылетел из Сизифа 16 мая 2006-го года.
------- Comment #2 From 2009-07-18 21:33:48 -------
Значит libfxscintilla20 может смело его обсолетить.
------- Comment #3 From 2009-07-19 01:42:42 -------
Это 1) проблема упаковки старого libfxscintilla, 2) к бинарному пакету
libfxscintilla20 никакого отношения не имеющая, потому как в
libfxscintilla-1.63-alt4 лежит libfxscintilla.so.17.
------- Comment #4 From 2009-07-20 00:38:22 -------
Пока не понял логики. Если новый пакет как-то замещает старый (не может встать
рядом), старый надо обсолетить.
------- Comment #5 From 2009-07-20 01:16:41 -------
Конфликт по файлу %_libdir/libfxscintilla.so, который должен лежать в -devel
пакете.  "Замещать" пакет с другим SONAME неправильно.
------- Comment #6 From 2009-07-20 22:55:02 -------
Тогда Conflicts