Bug 21109 - Падает практически сразу
: Падает практически сразу
Status: CLOSED FIXED
: Sisyphus
(All bugs in Sisyphus/tuxmathscrabble)
: unstable
: all Linux
: P3 normal
Assigned To:
:
:
:
:
:
  Show dependency tree
 
Reported: 2009-08-18 14:32 by
Modified: 2011-06-01 19:10 (History)


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2009-08-18 14:32:56
Версия tuxmathscrabble-0.5.4-alt2
$ tuxmathscrabble
Traceback (most recent call last):
  File "/usr/games/tuxmathscrabble", line 24, in <module>
    x=TuxMathScrabbleApp()
  File "/usr/lib/python2.5/site-packages/TuxMathScrabble/tms.py", line 57, in
__init__
    mode,level=prog.run()
  File "/usr/lib/python2.5/site-packages/TuxMathScrabble/tms.py", line 382, in
run
    for self.player_idx in range(2):self.draw_tiles()
  File "/usr/lib/python2.5/site-packages/TuxMathScrabble/tms.py", line 236, in
draw_tiles
    tile=self.make_tile(strval,uchar,ptval)
  File "/usr/lib/python2.5/site-packages/TuxMathScrabble/tms.py", line 169, in
make_tile
    img=pygame.Surface((tile_size,tile_size), flags=0, depth=0, masks=None)
ValueError: masks argument must be sequence of four numbers
Fatal Python error: (pygame parachute) Segmentation Fault
Аварийный останов
------- Comment #1 From 2011-05-25 00:13:32 -------
*** Bug 25665 has been marked as a duplicate of this bug. ***
------- Comment #2 From 2011-05-25 00:15:59 -------
Старая бага. Хорошо бы собрать свежую версию.
ping
------- Comment #3 From 2011-05-25 22:11:54 -------
Собираю. Через пару дней будет. Не успел протестировать пока.
------- Comment #4 From 2011-05-27 17:44:59 -------
tuxmathscrabble-0.7.4-alt1 -> sisyphus:

* Wed May 25 2011 Vitaly Lipatov <lav@altlinux> 0.7.4-alt1
- build new version (ALT bug #21109)
------- Comment #5 From 2011-05-30 23:46:14 -------
А в 5ке все также :(
------- Comment #6 From 2011-05-30 23:52:56 -------
(В ответ на комментарий №5)
> А в 5ке все также :(

2cas@: соберите для p5 и p6 версию их Сизифа, пожалуйста!
------- Comment #7 From 2011-05-31 10:52:23 -------
(В ответ на комментарий №6)
> 2cas@: соберите для p5 и p6 версию их Сизифа, пожалуйста!
Тестируется.

#46480 TESTED #1 [test-only] p5 tuxmathscrabble.git=0.7.4-alt0.M50P.1
------- Comment #8 From 2011-05-31 16:18:16 -------
В p6 не работает.
------- Comment #9 From 2011-05-31 16:23:17 -------
В p6 не работает, при запуске падает:
$ tuxmathscrabble 
Traceback (most recent call last):
  File "/usr/games/tuxmathscrabble", line 24, in <module>
    x=TuxMathScrabbleApp()
  File "/usr/lib/python2.6/site-packages/TuxMathScrabble/tms.py", line 56, in
__init__
    prog=TuxMathScrabble(mode,level,use_default_level)
  File "/usr/lib/python2.6/site-packages/TuxMathScrabble/tms.py", line 158, in
__init__
    self.admin.setup()
  File "/usr/lib/python2.6/site-packages/TuxMathScrabble/wxadmin.py", line 61,
in setup
    self.splitter = wx.SplitterWindow (self,wx.NewId(),style=wx.NO_3D)#|wxSP_3D
AttributeError: 'module' object has no attribute 'NO_3D'
$
------- Comment #10 From 2011-06-01 19:10:23 -------
на p5 tuxmathscrabble не ставится - хочет шрифты, которые нельзя поставить