Bug 21453 - Не работает получение почты по POP3
: Не работает получение почты по POP3
Status: CLOSED FIXED
: Sisyphus
(All bugs in Sisyphus/alterator-postfix-dovecot)
: unstable
: all Linux
: P3 normal
Assigned To:
:
:
: distro-blocker
:
: 19564 21454
  Show dependency tree
 
Reported: 2009-09-07 12:28 by
Modified: 2009-09-12 10:49 (History)


Attachments
diff -ru /usr/share/alterator-postfix-dovecot/dovecot /etc/dovecot (2.14 KB, patch)
2009-09-09 19:33, Andrey Cherepanov
no flags Details | Diff


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2009-09-07 12:28:37
На клиенте (KMail) прописываю аутентификацию и подключение через SSL/TLS.
Невозможно подключиться к серверу POP3.

Sep  7 12:25:19 ham1 dovecot: pop3-login: Login: user=<l1>, method=PLAIN,
rip=10.1.1.249, lip=10.1.0.18, TLS
Sep  7 12:25:19 ham1 dovecot: POP3(l1): mail_location not set and autodetection
failed: Mail storage autodetection failed with home=/home/l1
Sep  7 12:25:19 ham1 dovecot: POP3(l1): Fatal: Namespace initialization failed
------- Comment #1 From 2009-09-08 16:41:46 -------
Не воспроизводится.
Последовательность действий:
1. В альтераторе завести пользователя l1.
2. В почтовом клиенте завести учётную запись POP3

email: l1@test.spb.altlinux.ru
POP3: 192.168.3.254
SMTP: 192.168.3.254
login: l1
password: test
options: STARTTLS для POP3

3. Получение почты, журнал:

[16:34:46] POP3< +OK Dovecot ready.
[16:34:46] POP3> STLS
[16:34:46] POP3< +OK Begin TLS negotiation now.
** LibSylph-WARNING: 192.168.3.254: SSL certificate verify failed (18: self
signed certificate)

[16:34:47] POP3> USER l1
[16:34:47] POP3< +OK
[16:34:47] POP3> PASS ********
[16:34:47] POP3< +OK Logged in.
[16:34:47] POP3> STAT
[16:34:47] POP3< +OK 0 0
[16:34:47] POP3> QUIT
[16:34:47] POP3< +OK Logging out.

4. Журнал на сервере (/var/log/maillog):
Sep  8 16:34:54 server dovecot: pop3-login: Login: user=<l1>, method=PLAIN,
rip=192.168.3.1, lip=192.168.3.254, TLS
Sep  8 16:34:54 server dovecot: POP3(l1): Disconnected: Logged out top=0/0,
retr=0/0, del=0/0, size=0
------- Comment #2 From 2009-09-09 16:42:37 -------
Нет. Три попытки (без шифрования, SSL, TLS):
Sep  9 16:37:44 ham1 dovecot: pop3-login: Login: user=<l1>, method=PLAIN,
rip=10.1.1.249, lip=10.1.0.18
Sep  9 16:37:44 ham1 dovecot: POP3(l1): mail_location not set and autodetection
failed: Mail storage autodetection failed with home=/home/l1
Sep  9 16:37:45 ham1 dovecot: POP3(l1): Fatal: Namespace initialization failed
Sep  9 16:40:08 ham1 postfix/anvil[20414]: statistics: max connection rate
1/60s for (smtp:10.1.1.249) at Sep  9 16:36:48
Sep  9 16:40:08 ham1 postfix/anvil[20414]: statistics: max connection count 1
for (smtp:10.1.1.249) at Sep  9 16:36:48
Sep  9 16:40:08 ham1 postfix/anvil[20414]: statistics: max cache size 1 at Sep 
9 16:36:48
Sep  9 16:40:28 ham1 dovecot: pop3-login: Login: user=<l1>, method=PLAIN,
rip=10.1.1.249, lip=10.1.0.18, TLS
Sep  9 16:40:28 ham1 dovecot: POP3(l1): mail_location not set and autodetection
failed: Mail storage autodetection failed with home=/home/l1
Sep  9 16:40:29 ham1 dovecot: POP3(l1): Fatal: Namespace initialization failed
Sep  9 16:40:51 ham1 dovecot: pop3-login: Login: user=<l1>, method=PLAIN,
rip=10.1.1.249, lip=10.1.0.18, TLS
Sep  9 16:40:51 ham1 dovecot: POP3(l1): mail_location not set and autodetection
failed: Mail storage autodetection failed with home=/home/l1
Sep  9 16:40:51 ham1 dovecot: POP3(l1): Fatal: Namespace initialization failed
------- Comment #3 From 2009-09-09 17:21:20 -------
Тогда приложи diff -ru /usr/share/alterator-postfix-dovecot/dovecot
/etc/dovecot
------- Comment #4 From 2009-09-09 17:34:49 -------
И проверь, существует ли на сервере /home/l1/mail - эта директория создаётся
при первом обращении по POP3.
А ещё укажи "mail_debug = yes" в /etc/dovecot/dovecot.conf , тогда сообщения
про поиски inbox станут подробнее.
------- Comment #5 From 2009-09-09 18:10:25 -------
Ещё пришло в голову
# grep pam_mkhomedir /etc/pam.d/system-auth
Поскольку в system-auth-local этот плагин не используется.
------- Comment #6 From 2009-09-09 19:33:55 -------
Created an attachment (id=3859) [details]
diff -ru /usr/share/alterator-postfix-dovecot/dovecot /etc/dovecot
------- Comment #7 From 2009-09-09 19:38:19 -------
(В ответ на комментарий №4)
> И проверь, существует ли на сервере /home/l1/mail - эта директория создаётся
> при первом обращении по POP3.
ls: cannot access /home/l1/mail: No such file or directory
Не создаётся. /home/l1 есть.

> А ещё укажи "mail_debug = yes" в /etc/dovecot/dovecot.conf , тогда сообщения
> про поиски inbox станут подробнее.

Sep  9 19:37:18 ham1 dovecot: pop3-login: Login: user=<l1>, method=PLAIN,
rip=10.1.1.249, lip=10.1.0.18, TLS
Sep  9 19:37:18 ham1 dovecot: POP3(l1): Effective uid=5000, gid=5000,
home=/home/l1
Sep  9 19:37:18 ham1 dovecot: POP3(l1): cydir: mailbox location not given
Sep  9 19:37:18 ham1 dovecot: POP3(l1): cydir: Couldn't create mail storage :
Root mail directory not given
Sep  9 19:37:18 ham1 dovecot: POP3(l1): dbox: mailbox location not given
Sep  9 19:37:18 ham1 dovecot: POP3(l1): dbox: Couldn't create mail storage :
Root mail directory not given
Sep  9 19:37:18 ham1 dovecot: POP3(l1): maildir: access(/home/l1/Maildir, rwx):
failed: No such file or directory
Sep  9 19:37:18 ham1 dovecot: POP3(l1): maildir: couldn't find root dir
Sep  9 19:37:18 ham1 dovecot: POP3(l1): maildir: Couldn't create mail storage :
Root mail directory not given
Sep  9 19:37:18 ham1 dovecot: POP3(l1): mbox: root: access(/home/l1/mail, rwx)
failed: No such file or directory
Sep  9 19:37:18 ham1 dovecot: POP3(l1): mbox: root: access(/home/l1/Mail, rwx)
failed: No such file or directory
Sep  9 19:37:18 ham1 dovecot: POP3(l1): mbox: checking if we are chrooted:
Sep  9 19:37:18 ham1 dovecot: POP3(l1): mbox autodetect: data=
Sep  9 19:37:18 ham1 dovecot: POP3(l1): mbox autodetect: has .imap/:
stat(/.imap) failed: No such file or directory
Sep  9 19:37:18 ham1 dovecot: POP3(l1): mbox autodetect: has inbox:
stat(/inbox) failed: No such file or directory
Sep  9 19:37:18 ham1 dovecot: POP3(l1): mbox autodetect: has mbox: stat(/mbox)
failed: No such file or directory
Sep  9 19:37:18 ham1 dovecot: POP3(l1): mbox: root mail directory not found
Sep  9 19:37:18 ham1 dovecot: POP3(l1): mbox: Couldn't create mail storage :
Autodetection failed
------- Comment #8 From 2009-09-09 19:38:56 -------
(В ответ на комментарий №5)
> Ещё пришло в голову
> # grep pam_mkhomedir /etc/pam.d/system-auth
> Поскольку в system-auth-local этот плагин не используется.
[root@ham1 ~]# grep pam_mkhomedir /etc/pam.d/system-auth
session         required        pam_mkhomedir.so silent
------- Comment #9 From 2009-09-09 20:47:29 -------
(В ответ на комментарий №7)
Ерунда какая-то. У меня вместо этого:
> Sep  9 19:37:18 ham1 dovecot: POP3(l1): mbox: root mail directory not found
> Sep  9 19:37:18 ham1 dovecot: POP3(l1): mbox: Couldn't create mail storage : Autodetection failed

это:
> Sep  9 20:39:53 server dovecot: POP3(l2): mbox: root mail directory not found
> Sep  9 20:39:53 server dovecot: POP3(l2): mbox: root directory created: /home/l2/mail

Какая версия dovecot?
------- Comment #10 From 2009-09-09 22:03:28 -------
Попробуй указать в /etc/dovecot/dovecot.conf

mail_location = mbox:~/mail:INBOX=/var/mail/%u
------- Comment #11 From 2009-09-10 12:10:31 -------
(В ответ на комментарий №9)
> Какая версия dovecot?
dovecot-1.2.4-alt5
------- Comment #12 From 2009-09-10 12:13:39 -------
(В ответ на комментарий №10)
> Попробуй указать в /etc/dovecot/dovecot.conf
> 
> mail_location = mbox:~/mail:INBOX=/var/mail/%u
Да, так всё работает. Сделай дистрибутивно, пожалуйста.
------- Comment #13 From 2009-09-10 15:01:34 -------
(В ответ на комментарий №11)
> > Какая версия dovecot?
> dovecot-1.2.4-alt5

А, вот оно что. У меня на диске 1.1.6-alt3.
Ладно, добавлю mail_location.
------- Comment #14 From 2009-09-12 10:47:44 -------
*** Bug 21454 has been marked as a duplicate of this bug. ***
------- Comment #15 From 2009-09-12 10:49:04 -------
fixed in 0.3-alt3