Bug 21745 - file conflicts between evince and evince-gtk
: file conflicts between evince and evince-gtk
Status: CLOSED FIXED
: Sisyphus
(All bugs in Sisyphus/evince)
: unstable
: all Linux
: P3 normal
Assigned To:
:
:
:
:
:
  Show dependency tree
 
Reported: 2009-09-27 21:11 by
Modified: 2010-11-10 18:00 (History)


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2009-09-27 21:11:27
Сейчас в Сизифе есть два варианта сборки evince:
 - evince-2.28.0-alt1
 - evince-gtk-2.26.2-alt1
По смыслу это взаимоисключающие пакеты, однако в зависимостях пакетов это не
отражено, в результате apt может пытаться установить их одновременно, что
завершается ошибками из-за файловых конфликтов:

file /usr/lib64/evince/1/backends/comicsdocument.evince-backend from install of
libevince-2.28.0-alt1 conflicts with file from package
libevince-gtk-2.26.2-alt1
...
file /usr/bin/evince from install of evince-2.28.0-alt1 conflicts with file
from package evince-gtk-2.26.2-alt1
...

(конфликтуют и основные пакеты, и пакеты с библиотеками libevince и
libevince-gtk).
------- Comment #1 From 2010-09-28 17:36:31 -------
Добавил в evince-gtk 2.26.2-alt3 конфликты на evince, libevince,
libevince-devel
------- Comment #3 From 2010-11-10 18:00:56 -------
*** Bug 22767 has been marked as a duplicate of this bug. ***