Bug 21880 - не стартует графика на только что установленной системе (П5 20090908) на NVidia, но РАБОТАЕТ В РЕЖИМЕ LIVE CD
: не стартует графика на только что установленной системе (П5 20090908) на NVid...
Status: NEW
: ALT Linux Desktop
(All bugs in ALT Linux Desktop/installer)
: 5.0.0
: x86 Linux
: P3 blocker
Assigned To:
:
:
:
:
: 19564
  Show dependency tree
 
Reported: 2009-10-08 17:26 by
Modified: 2010-11-24 06:20 (History)


Attachments
Xorg.0.log после неудачного старта Xorg (6.86 KB, text/x-log)
2009-11-10 18:59, jazz4sad@gmail.com
no flags Details


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2009-10-08 17:26:27
не стартует графика, как на только что установленной системе (i586) (образ от
20090908), так и после обновления.

02:00.0 VGA compatible controller: nVidia Corporation G84 [GeForce 8600 GT]
(rev a1)
Subsystem: XFX Pine Group Inc. Device 228b
Flags: bus master, fast devsel, latency 0, IRQ16
Memory at ea000000 (32 bit, non-prefetchable) [size=16M]
Memory at d0000000 (64 bit, prefetchable) [size=256M]
Memory at e8000000 (64 bit, non-prefetchable) [size=32M]
I/O ports at 9000 [size=128]
[virtual] Expansion ROM at eb000000 [disabled] [size=128K]


ядро: оба 2.6.30-alt10 и -alt14

Xorg.log:
(EE) NVIDIA(0): Failed to initialize the NVIDIA graphics device PCI:2:0:0.
(EE) NVIDIA(0):     Please check your system's kernel log for additional error
(EE) NVIDIA(0):     messages and refer to Chapter 8: Common Problems in the
(EE) NVIDIA(0):     README for additional information.
(EE) NVIDIA(0): Failed to initialize the NVIDIA graphics device!
(II) UnloadModule: "nvidia"
(II) UnloadModule: "wfb"
(II) UnloadModule: "fb"
(EE) Screen(s) found, but none have a usable configuration.

Fatal server error:
no screens found

x11setupdrv / presetrv эффекта не дают.

dmesg:

[   33.698226] nvidia 0000:02:00.0: PCI INT A -> Link[APC6] -> GSI 16 (level,
low) -> IRQ 16
[   33.698234] nvidia 0000:02:00.0: setting latency timer to 64
[   33.698433] NVRM: loading NVIDIA UNIX x86 Kernel Module  185.18.36  Fri Aug
14 17:18:04 PDT 2009
[   34.444931] vmap allocation for size 16781312 failed: use vmalloc=<size> to
increase size.
[   34.445350] NVRM: RmInitAdapter failed! (0x26:0xffffffff:1096)
[   34.445357] NVRM: rm_init_adapter(0) failed

Интересно, что при загрузке в режиме liveCD с того же образа, графика НОРМАЛЬНО
РАБОТАЕТ, включая эффекты и 2х мониторную конфигурацию.

На ALT 4.1 со всеми ядрами графика также нормально работает.
------- Comment #1 From 2009-11-10 18:59:58 -------
Created an attachment (id=4055) [details]
Xorg.0.log после неудачного старта Xorg
------- Comment #2 From 2009-11-10 19:01:30 -------
(В ответ на комментарий №1)
> Created an attachment (id=4055) [details] [details]
> Xorg.0.log после неудачного старта Xorg

Наступил на странные грабельки при установке системы. При первой 
загрузке не стартует Xorg сервер и в лог пишет следующее:

Backtrace:
0: X(xorg_backtrace+0x3b) [0x81220ab]
1: X(xf86SigHandler+0x9e) [0x80c9abe]
2: [0xb8037400]

Fatal server error:
Caught signal 11.  Server aborting


Please consult the The X.Org Foundation support 
         at https://bugzilla.altlinux.org/
 for help. 
Please also check the log file at "/var/log/Xorg.0.log" for 
additional information.

Интересным образом решил проблему... Переписал в /etc/lilo.conf 
параметр vga="0x315" (default vga="0x314")...и о чудо, после 
перезагрузки Xorg стартанул.
------- Comment #3 From 2010-03-16 11:40:27 -------
Ещё на MX400 проявляется. Драйвер грузится тот же, что и для 440.
Зато работает c 2.6.27-ovz-smp
------- Comment #4 From 2010-03-17 16:24:53 -------
В качестве ping.

Варианты, которые видятся (исполнять, очевидно, должен инсталлятор, так что
перевешу-ка я баг на него). 

1. Вести блэклист для "проколовшихся" версий драйвера.
 1a) ставить вместо них nv или nouveau
 1b) или vga=normal в lilo.conf

2. Не вести блэклист. Использовать только последнюю версию nvidia, в случае,
если поддержка видеочипа уже убрана, использовать nv или nouveau, а
пользователю показывать инструкцию (или упомянуть, чтобы в /usr/share/doc
посмотрел), как он может попробовать использовать nvidia legacy и что делать,
если не выйдет.

Вообще, мне кажется, что 2 путь перспективнее.
------- Comment #5 From 2010-11-02 16:45:39 -------
(В ответ на комментарий №0)
> [   34.444931] vmap allocation for size 16781312 failed: use vmalloc=<size> to
> increase size.

Дубликат #24296 ?
------- Comment #6 From 2010-11-20 09:50:22 -------
ALT KDE beta обновил в том числе и ядро из:
ftp://ftp.altlinux.ru/pub/distributions/ALTLinux/cert6/.  MX-400 полет
нормальный заработала сразу на драйвере nvidia.
------- Comment #7 From 2010-11-24 06:20:05 -------
(В ответ на комментарий №6)
> ALT KDE beta обновил в том числе и ядро из:
> ftp://ftp.altlinux.ru/pub/distributions/ALTLinux/cert6/.  MX-400 полет
> нормальный заработала сразу на драйвере nvidia.

Собственно, баг от 2009-11. Ровно год назад... неужели ещё не "протух"? Тогда
грустно.