Bug 21989 - Не запускается alterator-x11 практически на любой системе
: Не запускается alterator-x11 практически на любой системе
Status: CLOSED FIXED
: Sisyphus
(All bugs in Sisyphus/alterator-x11)
: unstable
: all Linux
: P3 major
Assigned To:
:
:
: distro-blocker
:
: 19564
  Show dependency tree
 
Reported: 2009-10-19 12:03 by
Modified: 2010-10-27 07:40 (History)


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2009-10-19 12:03:25
На вчерашнем сизифе собрал свежий образ установочного диска. Итог: с данного
диска не запускается установку ни на одной машине что пробовал (например, на
ноутбуках с видео Intel X3100), работает только в VirtualBox - но и в нем
валится на этапе определения дисплея и установщик уходит в перезагрузку.
Дополнительные подробности можно почерпнуть здесь:
http://lists.altlinux.org/pipermail/devel/2009-October/176398.html.
------- Comment #1 From 2009-10-21 00:30:19 -------
Fix severity according to http://www.altlinux.org/BugSeverityPolicy
------- Comment #2 From 2009-10-21 10:13:49 -------
Это только в VirtualBox или в живой системе такая-же ситуация ?

Андрей, у нас воспроизводится ?
------- Comment #3 From 2009-10-21 10:23:13 -------
Это наложение нескольких ошибок.
Часть исправлена в alterator-alterator-x11-1.2-alt1 (генерация неправильного
xorg.conf),
часть в alterator-4.14-alt1 (падение при загрузке модуля настройки x11 в
инстоляторе)

Напишите подробнее, пожалуйста, если что-то осталось.
------- Comment #4 From 2009-10-21 11:12:43 -------
После вчерашнего обновления alterator-x11 стало лучше. В VirtualBox установка
проходит, но валится при загрузке. Итоговый xorg.conf получается такой:

Section "ServerFlags"
EndSection

Section "ServerLayout"
    Identifier     "Minimal layout"
    Screen         "Screen0"
EndSection

Section "Module"
    SubSection      "extmod"
               Option "omit xfree86-dga"
    EndSubSection
EndSection

Section "Device"
    Identifier "Card0|0"
    Driver "vesa"
EndSection

Section "Monitor"
    VertRefresh 
    HorizSync 
    Identifier "Monitor0|0"
EndSection

Section "Screen"
    DefaultDepth 24
    Identifier "Screen0"
    Device "Card0|0"
    Monitor "Monitor0|0"

    SubSection "Display"

      Modes auto
    EndSubSection
EndSection


Как видно, нет значений для VertRefresh и HorizSync в секции Monitor. Если их
удалить, система ругается на слово "auto" в секции Screen словами "is not valid
keyword for this section." 

Если и эту запись удалить, все запускается, правда, кривовато (например, в GDM
не видно вводимых букв в поле для ввода пароля и логина и подписей для этих
полей). 

Сейчас попробую на реальных машинах. О результатах отпишу чуть позже.
------- Comment #5 From 2009-10-21 11:29:30 -------
погоди на реальных, давай я это исправлю...
------- Comment #6 From 2009-10-21 15:01:54 -------
Исправлено в alterator-x11-1.3-alt1
Если осталось еще что-то, связанное с неправильной генерацией xorg.conf --
переоткрывайте, пожалуйста!