Bug 222 - can\'t rebuild
: can\'t rebuild
Status: CLOSED FIXED
: Sisyphus
(All bugs in Sisyphus/gnome-guile)
: unstable
: all Linux
: P4 major
Assigned To:
:
:
:
:
:
  Show dependency tree
 
Reported: 2001-12-10 21:12 by
Modified: 2003-08-25 15:18 (History)


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2001-12-10 21:12:59
результат сборки на altair:

checking for libraries... gtk+ Package gthread was not found in the pkg-config search path.
Perhaps you should add the directory containing `gthread.pc\'
to the PKG_CONFIG_PATH environment variable
No package \'gthread\' found
(gthread)
configure: error: An old version of gthread (version ) was found. You need at least version 1.2.6
configure: error: ./configure failed for guile-gtk

После исправления configure.in и configure в guile-gtk чтобы оно искало gthread-2.0 вместо gthread предыдущее место проходит нормально, но затем запускается autoconf.
В результате получаем:

checking for pkg-config... (cached) yes
./configure: line 5486: syntax error near unexpected token `GNOME_PKGCONFIG_CHECK_MODULES(GTK,\'
./configure: line 5486: `        GNOME_PKGCONFIG_CHECK_MODULES(GTK, gtk+:1.2.6 gthread-2.0:1.2.6)\'


Где-то потерялся файлик /usr/share/aclocal/gnome.ac (или что-то вроде)?
---

---

------- Comment #1 From 2002-03-30 19:53:50 -------
Нужен ли кому-нибудь этот пакет?
------- Comment #2 From 2002-03-30 19:53:50 -------
Нужен ли кому-нибудь этот пакет?
------- Comment #3 From 2002-03-30 20:04:36 -------
Исправлено в alt2
------- Comment #4 From 2002-03-30 20:04:36 -------
Исправлено в alt2