Bug 2233 - libpw file size exceeded
: libpw file size exceeded
Status: CLOSED WORKSFORME
: Sisyphus
(All bugs in Sisyphus/libpw)
: unstable
: all Linux
: P4 minor
Assigned To:
:
:
:
:
:
  Show dependency tree
 
Reported: 2003-02-13 16:52 by
Modified: 2005-06-01 00:52 (History)


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2003-02-13 16:52:47
при  компиляции программы с влюченым libpt.h
процес прерываается из-за ошибки

/usr/include/libpw/ptlib/semaphor.h:240:28: #include nested too deeply
i586-alt-linux-gcc: Internal error: File size limit exceeded (program cpp0)
Please submit a full bug report.
See &lt;URL:<a href="http://bugs.altlinux.ru/&gt">http://bugs.altlinux.ru/&gt</a>; for instructions.
===
#include &lt;stdio.h&gt;
#include &lt;stdlib.h&gt;
#include &lt;ptlib.h&gt;

int main(int argc,char *argv[])
{
printf(\&quot;Hello world\\n\&quot;);
return 1;
}
===
gcc -I/usr/include/libpw -o test main.c

ALT Linux Sisyphus (20030207)
2.4.20-alt0.8-up #1 Thu Dec 26 18:55:09 MSK 2002 i686 unknown unknown GNU/Linux
ReiserFS version 3.6.25
gcc2.96-2.96-alt3
gcc2.96-c++-2.96-alt3


все установки по умолчанию
---

---

------- Comment #1 From 2003-02-16 10:59:51 -------
Нужно использовать /usr/share/libpw/unix.mak
для включения в makefile. См. программы, использующие libpw
(например, gnomemeeting).
И то, что ваш пример вот так просто не компилируется,
не является Severity=block, мне кажется. Согласитесь, некомпилируемость у вас не влияет на выпуск нового продукта с использованием libpw :)
------- Comment #2 From 2003-02-16 10:59:51 -------
Нужно использовать /usr/share/libpw/unix.mak
для включения в makefile. См. программы, использующие libpw
(например, gnomemeeting).
И то, что ваш пример вот так просто не компилируется,
не является Severity=block, мне кажется. Согласитесь, некомпилируемость у вас не влияет на выпуск нового продукта с использованием libpw :)
------- Comment #3 From 2003-02-16 17:26:47 -------
Возможно не является, но при этом все равно остается проблема с GK (Gnu
GateKeeper)
Вылетел он с такой же ошибкой.
А он, как известно, использует именно эту библиотеку.
Ну да ладно.
------- Comment #4 From 2003-02-16 17:26:47 -------
Возможно не является, но при этом все равно остается проблема с GK (Gnu
GateKeeper)
Вылетел он с такой же ошибкой.
А он, как известно, использует именно эту библиотеку.
Ну да ладно.
------- Comment #5 From 2004-06-03 16:45:59 -------
Коли "ну да ладно" снижаю приоритет до minor 
 
------- Comment #6 From 2004-10-19 14:46:44 -------
Вроде больше нет претензий 
------- Comment #7 From 2004-10-19 14:48:09 -------
Вроде больше нет претензий 
------- Comment #8 From 2005-06-01 00:52:55 -------
закрываю