Bug 22336 - Can't pass command-line arguments
: Can't pass command-line arguments
Status: NEW
: Sisyphus
(All bugs in Sisyphus/tigervnc-server)
: unstable
: all Linux
: P3 normal
Assigned To:
:
:
:
:
:
  Show dependency tree
 
Reported: 2009-11-19 14:30 by
Modified: 2013-01-17 16:46 (History)


Attachments
Patch (1.01 KB, patch)
2009-11-19 14:30, Denis Yagofarov
no flags Details | Diff


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2009-11-19 14:30:25
Created an attachment (id=4067) [details]
Patch

With such config:
VNCSERVERS="1:user 2:user"
VNCSERVERARGS[2]="-geometry 1280x1024"
On the secound screen geometry is still 1024x768.
Attached patch fixes this problem.

tightvnc-server-1.5.0git-alt8
------- Comment #1 From 2009-11-21 20:45:38 -------
беру
------- Comment #2 From 2012-02-22 17:41:56 -------
*** Bug 26975 has been marked as a duplicate of this bug. ***
------- Comment #3 From 2012-02-22 17:43:06 -------
Дистр Кентавр 6.0 обновленный по сегодня 22.02.2012 из ветки p6
File:
/etc/sysconfig/vncservers
содержит только одну строку:
VNCSERVERS="user1:1 user2:2 user3:3"
При попытке добавить параметры:
VNCSERVERARGS[1]="-geometry 1280x1024"
VNCSERVERARGS[2]="-geometry 1024x768"
VNCSERVERARGS[3]="-geometry 1024x768"
после рестарта VNC сервера
эти три строки просто игнорируются, это и видно из /etc/rc0.d/K35vncserver
------- Comment #4 From 2012-02-22 17:57:42 -------
На Sisyphus.
------- Comment #5 From 2012-02-28 08:46:53 -------
Андрей, а какой пакет? 
http://www.sisyphus.ru/ru/srpm/tigervnc 
Здесь ничего нет!
А tightvnc я так и не нашел, это мета пакет?
------- Comment #6 From 2012-02-28 11:09:44 -------
(В ответ на комментарий №5)
> Андрей, а какой пакет? 
> http://www.sisyphus.ru/ru/srpm/tigervnc 
> Здесь ничего нет!
> А tightvnc я так и не нашел, это мета пакет?
По этой же ссылке, в разделе "Спек":
Provides: tightvnc = 1.7.6
Так что tigervnc провайдит tightvnc, что является правдой.
------- Comment #7 From 2012-02-29 18:26:35 -------
скачал я 1.0.90-alt6, поставил, предварительно удалив 1.0.90-alt5
ничего не изменилось. Он как игнорировал параметры vncserver-а так и
игнорирует!
А вот патч - да, помог!
------- Comment #8 From 2013-01-13 12:51:26 -------
А нельзя это опакетить в p6?
------- Comment #9 From 2013-01-17 16:46:00 -------
Валерий, что вы думаете по поводу этого патча?