Bug 22371 - Доступно всем...
: Доступно всем...
Status: CLOSED FIXED
: Sisyphus
(All bugs in Sisyphus/NetworkManager)
: unstable
: all Linux
: P3 normal
Assigned To:
:
:
:
:
:
  Show dependency tree
 
Reported: 2009-11-24 09:27 by
Modified: 2009-12-01 13:56 (History)


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2009-11-24 09:27:45
NetworkManager-0.7.996-alt2.git20091026
NetworkManager-gnome-0.7.996-alt1.git20091026

Проводная сеть настроена с помощью NM.
При запуске системы qutim начинает вопить, что нет сети и т.д.
Значит NM ещё не применил настройки.
Открываю "Сетевые соединения" > "Проводные" > "Изменить"
Ставлю галку "Доступно всем пользователям", жму "Применить", "Закрыть"
Снова жму на апплет в трее и открываю "Сетевые соединения" > "Проводные" >
"Изменить". Галочки нет. Куда она делась?
Можно как-то объяснить NM, чтоб при загрузке системы сеть поднималась, а не
после логона в сеанс?
------- Comment #1 From 2009-11-24 17:19:11 -------
rpm -qa | grep polkit
И есть ли в /var/log/messages строчка "Loaded plugin keyfile" при запуске NM?
------- Comment #2 From 2009-11-25 15:49:28 -------
(В ответ на комментарий №1)
> rpm -qa | grep polkit

rpm -qa|grep polkit
libpolkit-qt-gui-0.9.2-alt1
polkit-0.95-alt1
libpolkit-0.9-alt7
libpolkit-qt-core-0.9.2-alt1
libpolkit1-0.95-alt1
libpolkitkdeprivate4-4.3.3-alt2

> И есть ли в /var/log/messages строчка "Loaded plugin keyfile" при запуске NM?

Да, есть.
------- Comment #3 From 2009-11-25 20:24:01 -------
Поставьте polkit-gnome. Убедитесь, что
/usr/libexec/polkit-1/polkit-gnome-authentication-agent-1 запущен.
------- Comment #4 From 2009-11-27 08:34:58 -------
(В ответ на комментарий №3)
> Поставьте polkit-gnome. Убедитесь, что
> /usr/libexec/polkit-1/polkit-gnome-authentication-agent-1 запущен.

Ну как так - поставьте?
Наверное надо зависимость добавить, чтоб с установкой NetworkManager-gnome по
зависимостям ставился polkit-gnome?
------- Comment #5 From 2009-11-27 15:16:31 -------
(В ответ на комментарий №4)
> Ну как так - поставьте?
> Наверное надо зависимость добавить, чтоб с установкой NetworkManager-gnome по
> зависимостям ставился polkit-gnome?

Да, конечно. Это был рецепт, чтобы заработало вот прям сейчас.
------- Comment #6 From 2009-12-01 13:56:51 -------
NetworkManager-gnome-0.7.996-alt2.git20091124 -> sisyphus:

* Fri Nov 27 2009 Mikhail Efremov <sem@altlinux> 0.7.996-alt2.git20091124

- add polkit-gnome require (closes #22371).