Bug 22385 - get_ports_from_reg fails
: get_ports_from_reg fails
Status: CLOSED WORKSFORME
: Sisyphus
(All bugs in Sisyphus/wine)
: unstable
: all Linux
: P3 normal
Assigned To:
:
:
:
:
:
  Show dependency tree
 
Reported: 2009-11-24 22:07 by
Modified: 2011-04-02 17:14 (History)


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2009-11-24 22:07:03
wine-1.1.29-alt2
libwine-1.1.29-alt2

How to reproduce:

Put the program plotcut.exe downloadable from
http://www.dgi-net.ru/support/downloads.html#d12 (Программа для вывода
изображений на режущий плоттер) to, say, .wine/dosdevices/c:/ ;

[ivan@dell ~]$ ln -s /WIN/WINDOWS/system32/mfc40.dll
~/.wine/dosdevices/c\:/windows/system32/
[ivan@dell ~]$ wine 'c:\plotcut.exe'
Warning: could not find DOS drive for current working directory '/home/ivan',
starting in the Windows directory.
Warning: could not find DOS drive for current working directory '/home/ivan',
starting in the Windows directory.
fixme:exec:SHELL_execute flags ignored: 0x00000100
[ivan@dell ~]$ 

Push the third button from the right (to set the size of the sheet --
"Параметры документа > Размер листа"), press the button "Опрос плоттера"
("Query the plotter"); then press "Изменить порт" (change the port); now,
you'll see the following output in the terminal:

err:localspl:get_ports_from_reg failed with 2 for
L"Software\\Microsoft\\Windows NT\\CurrentVersion\\Ports"
err:localspl:get_ports_from_reg failed with 2 for
L"Software\\Microsoft\\Windows NT\\CurrentVersion\\Ports"
err:localspl:get_ports_from_reg failed with 2 for
L"Software\\Microsoft\\Windows NT\\CurrentVersion\\Ports"
err:localspl:get_ports_from_reg failed with 2 for
L"Software\\Microsoft\\Windows NT\\CurrentVersion\\Ports"

and the list of ports is empty.

But what I wanted to do was to select COM1 (which is set up for wine:

$ l .wine/dosdevices/
total 0
drwxrwxr-x 3 ivan ivan 168 Ноя 24 20:59 ../
lrwxrwxrwx 1 ivan ivan  11 Ноя 24 15:04 a: -> /mnt/floppy/
lrwxrwxrwx 1 ivan ivan  10 Ноя 24 15:04 com1 -> /dev/ttyS0
lrwxrwxrwx 1 ivan ivan  10 Ноя 24 15:04 com2 -> /dev/ttyS1
lrwxrwxrwx 1 ivan ivan  20 Ноя 24 15:04 d: -> /home/ivan/Documents/
lrwxrwxrwx 1 ivan ivan  10 Ноя 24 15:04 e: -> /mnt/cdrom/
lrwxrwxrwx 1 ivan ivan  10 Ноя 24 15:04 e:: -> /dev/cdrom
lrwxrwxrwx 1 ivan ivan   8 Ноя 24 15:04 lpt1 -> /dev/lp0
drwxrwxr-x 4 ivan ivan 136 Ноя 24 14:59 c:/
drwxrwxr-x 3 ivan ivan 240 Сен 30  2006 ./
$ 

), but I can't do this, because the query for the ports to the "Registry"
fails.
------- Comment #1 From 2009-11-24 22:29:52 -------
Surprisingly, I have discovered that the same program works well under
wine-vanilla-1.1.26-alt2.1: there is a list of ports and it includes COM1.

Perhaps, that's due to wine having updated my configuration:

$ wine 'c:\plotcut.exe'
Warning: could not find DOS drive for current working directory '/home/ivan',
starting in the Windows directory.
err:module:import_dll Library shdocvw.dll (which is needed by
L"c:\\windows\\system32\\iexplore.exe") not found
err:module:LdrInitializeThunk Main exe initialization for
L"c:\\windows\\system32\\iexplore.exe" failed, status c0000135
Could not load wine-gecko. HTML rendering will be disabled.
wine: configuration in '/home/ivan/.wine' has been updated.

Cf.:

$ fgrep -1 COM1 .wine/*
.wine/system.reg-[Software\\Microsoft\\Windows NT\\CurrentVersion\\Ports]
1259086902
.wine/system.reg:"COM1:"="9600,n,8,1"
.wine/system.reg-"COM2:"="9600,n,8,1"
--
.wine/user.reg-[Software\\    \\PlotCut\\Settings\\Default] 1259087124
.wine/user.reg:"Port"="COM1"
.wine/user.reg-
$
------- Comment #2 From 2011-01-08 15:12:36 -------
Сейчас всё должно быть хорошо на wine >= 1.3.10
------- Comment #3 From 2011-04-02 17:14:16 -------
Закрываю, на новом wine должна работать.