Bug 22501 - doesn't start over "ssh -X -Y"
: doesn't start over "ssh -X -Y"
Status: CLOSED WORKSFORME
: Branch 5.0
(All bugs in Branch 5.0/midori)
: unspecified
: all Linux
: P3 normal
Assigned To:
:
:
:
:
:
  Show dependency tree
 
Reported: 2009-12-10 21:17 by
Modified: 2011-08-24 11:46 (History)


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2009-12-10 21:17:45
midori-0.1.5-alt1

How to reproduce:

do "ssh -X -Y" to a remote host with midori, try to start it:

$ midori

(midori:32404): Unique-DBus-WARNING **: Unable to open a connection to the
session bus: dbus-launch failed to autolaunch D-Bus session: Option
`--close-stderr' is unknown.


(midori:32404): Unique-DBus-WARNING **: Unable to connect to the running
instance, aborting.

It shows an error message: "An instance of Midori is already running but not
responding."

Expected: it starts over the remote connection, as it does on this system in a
local X session.

More info: 

$ rpm -qa '*dbus*'
libdbus-glib-doc-0.74-alt2
libdbus-qt-0.62-alt7
ndesk-dbus-glib-0.4.1-alt3
kdbus-0.8.6-alt3
lsdbus-0.1-alt1
libdbus-glib-0.74-alt2
libqt4-dbus-4.5.3-alt2.M51.1
dbus-tools-1.0.2-alt4
edbus-0.5.0.050-alt1
dbus-1.1.4-alt1
dbus-tools-gui-1.0.2-alt4
vlc-plugin-dbus-0.9.6-alt1
qmmp-dbuscontrol-0.2.3-alt3
python-module-dbus-0.82.4-alt2.1
ndesk-dbus-0.6.0-alt3
libdbus-1.1.4-alt1
libedbus-0.5.0.050-alt1
$
------- Comment #1 From 2009-12-10 22:41:20 -------
This is also true for 

midori-0.2.0-alt1
libwebkit-1.1.15.3-alt1
.

Perhaps, (old) dbus is the reason for this...
------- Comment #2 From 2011-08-24 10:16:21 -------
Ping?
------- Comment #3 From 2011-08-24 11:46:57 -------
У меня этот баг не воспроизводился раньше (на 5.1) и не воспроизводится сейчас
(на 6 и Sisyphus). 5.0 мертвый бранч - закрываю.