Bug 22992 - mypaint падает на проверке версии numpy
: mypaint падает на проверке версии numpy
Status: CLOSED FIXED
: Sisyphus
(All bugs in Sisyphus/mypaint)
: unstable
: all Linux
: P3 normal
Assigned To:
:
:
:
:
:
  Show dependency tree
 
Reported: 2010-02-18 20:25 by
Modified: 2010-02-21 17:39 (History)


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2010-02-18 20:25:52
Установлено из сизифа:

mypaint-0.8.0-alt1
python-module-pygoogle-0.6-alt0.2.1.1
python-module-protobuf-2.1.0-alt1.1
python-module-numpy-1.5.0-alt1.svn20100120.1

mypain падает:

zver@msi ~/develop % mypaint
Psyco being used
/usr/lib/python2.6/site-packages/pygoogle/google.py:58: DeprecationWarning:
SOAPpy not imported. Trying legacy SOAP.py.
  import GoogleSOAPFacade
confpath = /home/zver/.mypaint/
RuntimeError: module compiled against API version 3 but this version of numpy
is b7c09c80
zsh: segmentation fault  mypaint
------- Comment #1 From 2010-02-19 13:01:28 -------
x86_64?
------- Comment #2 From 2010-02-19 13:30:04 -------
нет, i586
------- Comment #3 From 2010-02-19 16:08:01 -------
У Вас старый python-module-pygoogle. Попробуйте обновиться до 
0.6-alt0.3.

Если не поможет, нужно попробовать пересобрать protobuf, сообщите, если что,
соберу.
------- Comment #4 From 2010-02-19 17:39:58 -------
Похоже у вас локальная проблема. MyPaint запускается и работает на двух живых
машинах со свежим сизифом. Установленный в пустой контейнер тоже работает, то
есть с зависимостями порядок.
------- Comment #5 From 2010-02-19 21:01:20 -------
обновил до python-module-pygoogle-0.6-alt0.3
проблема осталась. Это воспроизводится и у vvk@
Если работает в пустом контейнере, то тогда действительно проблема локальная.
интересно в чем.
------- Comment #6 From 2010-02-19 22:56:45 -------
"mypaint-0.8.0-alt1"

Дайте ссылку на git.alt этой штуковины.

PS. Надеюсь, оно собиралось из git, а не из srpm? Если второе, я не участвую.
------- Comment #7 From 2010-02-20 16:06:18 -------
Судя по всему мейнтейнер не использует git, но все равно gear-репо есть:
git://git.altlinux.org/srpms/m/mypaint.git
------- Comment #8 From 2010-02-21 09:08:18 -------
В общем, написал скриптик, чтобы прогонял через strace, брал все open вызовы и
получал по этим файлам список пакетов, который зайдествованы в запуске mypaint.
Стал обновлять по одному. после обновления до
python-module-pygtk 2.17.0-alt3
а вместе с ним по зависимостям
python-module-pygtk-libglade 2.17.0-alt3

mypaint запустился.

интересно, почему так влиял pygtk.
Нужно поставить более жесткую зависимость на этот пакет
------- Comment #9 From 2010-02-21 09:18:57 -------
(In reply to comment #8)
> 
> mypaint запустился.
> 
> интересно, почему так влиял pygtk.
> Нужно поставить более жесткую зависимость на этот пакет

Не нужно. Обновляйтесь как следует.
------- Comment #10 From 2010-02-21 17:39:26 -------
Всех не заставишь. Я уже говорил, что мейнтейнеров много, и многие не слушают
чужие рекомендации (как то обновлять _ключевые_ пакеты вслед да NumPy, если он
как-то с ним связан). Я всё не могу поймать момент, чтобы составить такой
список: слишком разные целевые группы, слишком неопределённо, но определённо
немалое количество.