Bug 2300 - \'g++\' command not available after install
: \'g++\' command not available after install
Status: CLOSED WORKSFORME
: Sisyphus
(All bugs in Sisyphus/gcc2.96-c++)
: unstable
: all Linux
: P5 minor
Assigned To:
:
:
:
:
:
  Show dependency tree
 
Reported: 2003-02-25 12:01 by
Modified: 2005-10-16 16:43 (History)


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2003-02-25 12:01:32
Похоже, во время установки gcc2.96-c++ не устанавливается update-alternatives
на /usr/bin/g++.

Например, сборка ядра 2.4.20-alt5 на этом останавливается:
/home/vyt/RPM/BUILD/linux-2.4.20/scripts/pathdown.sh: line 4: TOPDIR: parameter
null or not set
make: Entering directory `/home/vyt/RPM/BUILD/linux-2.4.20/DVB/driver\'
g++ -O2 -o fdump fdump.cc
make: g++: Command not found
make: *** [fdump] Error 127

---

---
------- Comment #1 From 2003-02-25 12:11:33 -------
Кстати, после выполнения
# select-gcc auto
/usr/bin/g++
появился и указывает на /etc/alternatives/g++, который указывает на /usr/bin/gcc_wrapper
------- Comment #2 From 2003-02-25 12:11:33 -------
Кстати, после выполнения
# select-gcc auto
/usr/bin/g++
появился и указывает на /etc/alternatives/g++, который указывает на /usr/bin/gcc_wrapper
------- Comment #3 From 2003-06-20 15:03:45 -------
Unable to reproduce this.
------- Comment #4 From 2003-06-20 15:03:45 -------
Unable to reproduce this.