Bug 23554 - Просьба портировать в бранч 5.1
: Просьба портировать в бранч 5.1
Status: CLOSED FIXED
: Sisyphus
(All bugs in Sisyphus/midori)
: unstable
: all Linux
: P3 normal
Assigned To:
:
:
:
:
:
  Show dependency tree
 
Reported: 2010-05-30 12:43 by
Modified: 2010-06-03 21:46 (History)


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2010-05-30 12:43:26
Доброго времени. Сабж.
------- Comment #1 From 2010-06-02 02:51:14 -------
Попробовал собрать его для 5.1 - не подошел по зависимостям.
Сборка останавливается на:
Checking for libsoup-2.4 >= 2.29.3             : no 
Checking for libsoup-2.4 >= 2.29.91            : no 
Ментейнер данных пакетов shaba... 
To shaba@: Возможно ли собрать новую версию libsoup для 5.1?
------- Comment #2 From 2010-06-02 12:24:35 -------
в бранч 5.1 находится gnome-2.28. Собирать libsoup-2.30 туда никто не
планировал. Изменений в libsoup-2.30 достаточно много, как это отразится на
gnome боюсь предсказать.
PS: последнее время libsoup собирал aris@, ставлю его в копию.
------- Comment #3 From 2010-06-03 20:40:25 -------
(В ответ на комментарий №1)
> Попробовал собрать его для 5.1 - не подошел по зависимостям.
> Сборка останавливается на:
> Checking for libsoup-2.4 >= 2.29.3             : no 
> Checking for libsoup-2.4 >= 2.29.91            : no 

На самом деле сборка останавливалась на компиляции расширения
external-applications.vala. Там используются конструкции языка vala,
появившиеся начиная с версии 0.7.8 (а в бранче 5.1 - 0.7.7).

Midori 0.2.6 отправлен в Sisyphus и 5.1
------- Comment #4 From 2010-06-03 21:46:47 -------
Класс! Спасибо!