Bug 23663 - Возобновление поддержки Пиктомира
: Возобновление поддержки Пиктомира
Status: CLOSED FIXED
: Sisyphus
(All bugs in Sisyphus/kumir)
: unstable
: all Linux
: P3 normal
Assigned To:
:
:
:
:
: 22919 23155
  Show dependency tree
 
Reported: 2010-06-24 19:07 by
Modified: 2011-12-14 18:35 (History)


Attachments
отчет пользователя об ошибках (589.93 KB, application/vnd.oasis.opendocument.text)
2010-06-24 19:08, Vladimir Cherny
no flags Details


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2010-06-24 19:07:00
В интерфейсе управления не отображаются кнопки "вперед", также не отображаются
кнопки команд на поле текста программы.
Файл с отчетом пользователя прилагаю.
------- Comment #1 From 2010-06-24 19:08:45 -------
Created an attachment (id=4437) [details]
отчет пользователя об ошибках
------- Comment #2 From 2010-06-24 19:30:06 -------
Проблема известная, обсуждалась вот здесь:
http://forum.altlinux.org/index.php/topic,4659.msg82682.html#msg82682

Проблема устраняется обновлением библиотеки qt4 до версии 4.6. Обновить можно
из Branch/5.1. При этом в p5 версия qt4 обновляться не будет, поэтому в p5
ошибка исправляться не будет.

Кроме того, Пиктомир в настоящее время не поддерживается в ALT Linux и удален
из 5.1 и Сизифа, поскольку апстрим не хочет выпускать публичные версии.

Наличие Пиктомира в p5 - это оплошность, на момент появления Пиктомира в p5 он
не распространялся под свободной лицензией (хотя и был доступен из SVN).

В ближайшее время я планирую обновление пакета с Кумиром в p5, при этом
Пиктомир будет удален.
------- Comment #3 From 2011-12-08 10:43:21 -------
> Пиктомир в настоящее время не поддерживается в ALT Linux и удален
> из 5.1 и Сизифа, поскольку апстрим не хочет выпускать публичные версии.
> 
> Наличие Пиктомира в p5 - это оплошность, на момент появления Пиктомира в p5 он
> не распространялся под свободной лицензией (хотя и был доступен из SVN).
> 
> В ближайшее время я планирую обновление пакета с Кумиром в p5, при этом
> Пиктомир будет удален.

Тут - http://www.piktomir.ru - пишут:

> ПиктоМир распространяется свободно на условиях лицензии GNU 2.0

В апстримном тарболле тоже лежит LICENSE.GPL 

Если неправильная лицензия - единственная причина отказа от поддержки
Пиктомира, то может есть смысл возобновить ее?
------- Comment #4 From 2011-12-08 12:39:47 -------
Лицензия на Пиктомир была изменена, в том числе и на основании моих просьб.

Но у меня нет возможности поддерживать Пиктомир.

Есть желающие собрать пакет и его поддерживать?

Тем более, что Пиктомир с Кумиром сейчас никак не связан.
------- Comment #5 From 2011-12-13 21:39:20 -------
1. Желающих собрать пиктомир для ALT Linux не видно => перевесить не на кого.

2. В любом случае, пиктомир нужно собирать отдельным пакетом, к пакету kumir
вопрос прямого отношения не имеет.

Закрываю.
------- Comment #6 From 2011-12-13 22:49:05 -------
Переоткрываю и перевешиваю на nobody. Ищется мейнтейнер.
------- Comment #7 From 2011-12-14 16:57:58 -------
(В ответ на комментарий №6)
> Переоткрываю и перевешиваю на nobody. Ищется мейнтейнер.

Ну раз гора не идет к Магомету - отправил в Сизиф то, что у меня собралось и
вроде бы заработало.
------- Comment #8 From 2011-12-14 18:35:44 -------
(В ответ на комментарий №7)
> (В ответ на комментарий №6)
> > Переоткрываю и перевешиваю на nobody. Ищется мейнтейнер.
> 
> Ну раз гора не идет к Магомету - отправил в Сизиф то, что у меня собралось и
> вроде бы заработало.

Евгений, спасибо!
Владимир, проверьте, пожалуйста.