Bug 23769 - не запускается
: не запускается
Status: CLOSED FIXED
: Sisyphus
(All bugs in Sisyphus/mypaint)
: unstable
: all Linux
: P3 normal
Assigned To:
:
:
:
:
:
  Show dependency tree
 
Reported: 2010-07-14 14:06 by
Modified: 2010-07-26 14:28 (History)


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2010-07-14 14:06:32
после установки mypaint не запускается:

$ mypaint 
RuntimeError: module compiled against ABI version 1000009 but this version of
numpy is 2000000

We are not correctly installed or compiled!
script: "/usr/bin/mypaint"
deduced prefix: "/usr"
lib_shared: "/usr/share/mypaint/"
lib_compiled: "/usr/lib64/mypaint/"

Traceback (most recent call last):
  File "/usr/bin/mypaint", line 112, in <module>
    datapath, confpath, localepath = get_paths()
  File "/usr/bin/mypaint", line 62, in get_paths
    from lib import mypaintlib
  File "/usr/share/mypaint/lib/mypaintlib.py", line 25, in <module>
    _mypaintlib = swig_import_helper()
  File "/usr/share/mypaint/lib/mypaintlib.py", line 17, in swig_import_helper
    import _mypaintlib
ImportError: numpy.core.multiarray failed to import
------- Comment #1 From 2010-07-26 13:00:00 -------
Тут, как обычно при таких сообщениях, нужна банальная пересборка.
------- Comment #2 From 2010-07-26 14:28:07 -------
mypaint-0.8.2-alt2 -> sisyphus:

* Mon Jul 26 2010 Yuri N. Sedunov <aris@altlinux> 0.8.2-alt2
- rebuild against current numpy (closes #23769)