Bug 2406 - dhcpcd not compatible with chrooted resolver
: dhcpcd not compatible with chrooted resolver
Status: CLOSED FIXED
: Sisyphus
(All bugs in Sisyphus/dhcpcd)
: unstable
: all Linux
: P4 minor
Assigned To:
:
:
:
:
: 3005
  Show dependency tree
 
Reported: 2003-03-22 20:28 by
Modified: 2004-03-22 13:14 (History)


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2003-03-22 20:28:15
when network interface is configured via DHCP first time, chrooted environments
can get outdated and resolving may not work as a consequence.

\"cheap\" workaround could be running update_chrooted after dhcpcd in
networking scripts, but proper one seems to involve dhcpcd.exe script as per
documentation.
---

---
this is a practical and not theoretical prob^Wglitch.
------- Comment #1 From 2003-10-20 13:27:36 -------
*** Bug 3184 has been marked as a duplicate of this bug. ***
------- Comment #2 From 2003-10-20 15:06:10 -------
(see also rider's comments on #3184)

would be the best if we could figure out whether resolv.conf has changed and run
update_chrooted only when it is so.  some backup & cmp should do.
------- Comment #3 From 2003-10-20 19:50:26 -------
Try 1.3.22pl4-alt1 
------- Comment #4 From 2003-10-22 15:08:54 -------
verified as fixed in dhcpcd-1.3.22pl4-alt1