Bug 24072 - fix LDAP Authentication
: fix LDAP Authentication
Status: CLOSED WONTFIX
: Sisyphus
(All bugs in Sisyphus/redmine)
: unstable
: all Linux
: P3 normal
Assigned To:
:
:
:
: 24379
:
  Show dependency tree
 
Reported: 2010-09-13 22:39 by
Modified: 2015-04-08 16:58 (History)


Attachments
патч (87 bytes, url)
2010-09-13 22:40, Timur Batyrshin
no flags Details
патч (428 bytes, patch)
2010-09-13 22:41, Timur Batyrshin
no flags Details | Diff


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2010-09-13 22:39:15
Для того, чтобы заработал вход LDAP, необходимо подключить свежую версию
библиотеки Net::LDAP — в настоящее время использует носимая в недрах пакета
протухшая 0.0.4, которая не работает с Ruby 1.9.
Предлагаю ее из пакета удалить и поставить зависимость на ruby-net-ldap.

Возникающую при этом проблему с созданием «на лету» пользователей из LDAP
(ошибка конвертации из ASCII-8BIT в UTF-8) можно решить, например, следующим
патчем:
------- Comment #1 From 2010-09-13 22:40:18 -------
Created an attachment (id=4536) [details]
патч
------- Comment #2 From 2010-09-13 22:41:45 -------
Created an attachment (id=4537) [details]
патч

Блин, что-то ссылка не вставилась нормально. Вот сам патч.
------- Comment #3 From 2010-09-13 23:04:14 -------
ACK.  У меня по плану ruby 1.9.2, потом уже redmine 1.0.1.
------- Comment #4 From 2015-04-08 16:58:05 -------
redmine в сизифе больше нет.