Bug 24109 - very old version
: very old version
Status: CLOSED FIXED
: Sisyphus
(All bugs in Sisyphus/maxima)
: unstable
: all Linux
: P3 normal
Assigned To:
:
:
:
:
:
  Show dependency tree
 
Reported: 2010-09-19 05:23 by
Modified: 2010-11-26 23:14 (History)


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2010-09-19 05:23:48
Список исправленных багов на maxima.sf.net. Кроме того там существенно обновлен
пакет рисования "draw" и много чего другого.
Пытался пересобрать версию 5.22.1 под себя и вижу что на нынешнем сизифе пакет
emacs-maxima сломался:

The following packages have unmet dependencies:
  emacs-maxima: Depends: texmf(latex/maxima) but it is not installable
E: Broken packages

в спеке это вообще не упоминается
------- Comment #1 From 2010-09-20 11:54:28 -------
Помогите Илье?  Возможно, для начала отодрав этот подпакет (%def_disable и
%if_disabled...%endif).
------- Comment #2 From 2010-09-20 22:20:49 -------
(В ответ на комментарий №1)
> Помогите Илье?  Возможно, для начала отодрав этот подпакет (%def_disable и
> %if_disabled...%endif).
Это то я могу, пакет пересоберется, а вот все остальное мне слабо ( отправить
пакет в сизиф).
------- Comment #3 From 2010-09-26 04:59:02 -------
(В ответ на комментарий №1)
> Помогите Илье?  Возможно, для начала отодрав этот подпакет (%def_disable и
> %if_disabled...%endif).

проблема наведенная от пакета emacs-mode-auctex, который привязан 
texmf-latex-preview, а этот в свою очередь к  
/usr/share/texmf
нужна ли эта зависимость? Пока незнаю, по-моему latex-preview
работает с texlive без проблем
------- Comment #4 From 2010-10-13 07:34:41 -------
Похоже на разговор с самим собой. Видимо, больше пользователей maximы в сизифе
нет.
> (В ответ на комментарий №1)
> > Помогите Илье?  Возможно, для начала отодрав этот подпакет (%def_disable и
> > %if_disabled...%endif).
> 
> проблема наведенная от пакета emacs-mode-auctex, который привязан 
> texmf-latex-preview, а этот в свою очередь к  
> /usr/share/texmf
 Вообщем я в этом месте ошибся. Хотя в тот момент это работало. Сейчас,
(сегодня, 11.10.10) уже нет. В спеке нужно поменять следующий раздел:
%files -n emacs-maxima
%emacs_maxima_dir
%_sysconfdir/emacs/site-start.d/*.el
%_datadir/texmf/tex/latex/emaxima
%exclude %_texmfmain/tex/latex/emaxima/emaxima.sty

Это временно решает проблему ( до следующей переделки texa)
Однако баг #24821 остается актуальным.
------- Comment #5 From 2010-10-13 09:21:10 -------
"Видимо, больше пользователей maximы в сизифе нет."

Нет, видимо, больше пользователей emacs, юзающих maxima, нет ;)
------- Comment #6 From 2010-10-13 10:06:51 -------
(В ответ на комментарий №5)
> "Видимо, больше пользователей maximы в сизифе нет."
> 
> Нет, видимо, больше пользователей emacs, юзающих maxima, нет ;)

Есть ли еще редактор который можно использовать как ide для maxima?
------- Comment #7 From 2010-10-13 10:09:29 -------
Мне хватает maxima-xmaxima. А есть ещё wxMaxima.

Не знаю, насколько это попадает в категорию "IDE", но меня устраивает.
------- Comment #8 From 2010-10-13 19:26:44 -------
(В ответ на комментарий №7)
> Мне хватает maxima-xmaxima. А есть ещё wxMaxima.
> 
> Не знаю, насколько это попадает в категорию "IDE", но меня устраивает.

Увы, но и xmaxima и wxmaxima годится только для "эпизодических" вычислений,
для вывода результата на экран. Для кода необходим хороший редактор+ среда для
запуска. У меня уже мегабайты кода на maxima. Не забудем, также что максима
написана на лисп. Wxmaxima, кстати тратит много времени для вывода результата
на экран, вместо непосредственных вычислений
------- Comment #9 From 2010-11-26 23:14:04 -------
Исправлено в maxima-5.22.1-alt0.1

насчет emacs - не уверен, тестируйте