Bug 24141 - wrong "browscap" setting for CLI version
: wrong "browscap" setting for CLI version
Status: CLOSED FIXED
: Sisyphus
(All bugs in Sisyphus/php5)
: unstable
: all Linux
: P3 normal
Assigned To:
:
:
:
:
:
  Show dependency tree
 
Reported: 2010-09-22 14:17 by
Modified: 2010-09-28 01:06 (History)


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2010-09-22 14:17:54
php5-5.3.3.20100722-alt1

$ php --version                 
PHP Warning:  Cannot open '@PHP_BROWSCAP@' for reading in Unknown on line 0
PHP 5.3.3 with Suhosin-Patch (cli) (built: Sep 17 2010 12:40:18) 
Copyright (c) 1997-2009 The PHP Group
Zend Engine v2.3.0, Copyright (c) 1998-2010 Zend Technologies
    with Suhosin v0.9.32.1, Copyright (c) 2007-2010, by SektionEins GmbH

В файле /etc/php/5.3/cli/php.ini по умолчанию указано:

[browscap]
; http://php.net/browscap
browscap = "@PHP_BROWSCAP@"

Для CLI-версии файл browscap.ini действительно не имеет смысла - в таком случае
эту строку стоит совсем убрать из файла конфигурации, тогда предупреждение не
выдаётся.
------- Comment #1 From 2010-09-23 14:33:05 -------
Конечно, оно попало туда случайно, при копировании нового конфига.

Коллеги, посмотрите пожалуйста - может быть стоит ещё какие-то дефолты
поправить в конфигурационных файлах.
------- Comment #2 From 2010-09-24 00:03:04 -------
(In reply to comment #1)
> может быть стоит ещё какие-то дефолты
> поправить в конфигурационных файлах.

Этот вопрос лучше бы задать где-нибудь в sisyphus@. Хотя я слабо верю в
возможность найти компромисс в одном-единственном php.ini, потому и чиню
control.
------- Comment #3 From 2010-09-28 01:06:07 -------
php5-5.3.3.20100722-alt2 -> sisyphus:

* Mon Sep 27 2010 Anton Farygin <rider@altlinux> 5.3.3.20100722-alt2
- removed php5-pdo provides (closes: #24139)
- removed browsecap section from cli config (closes: #24141)
- fixed phpinfo (by Sergey Kurakin)
- disabled fileinfo (should be used as extension, Sergey Kurakin)