Bug 24209 - Неработоспособный arepo репозиторий
: Неработоспособный arepo репозиторий
Status: CLOSED FIXED
: Sisyphus
(All bugs in Sisyphus/arepo)
: unstable
: x86_64 Linux
: P3 normal
Assigned To:
:
:
: distro-blocker
:
: 23155
  Show dependency tree
 
Reported: 2010-10-03 13:36 by
Modified: 2010-10-26 15:33 (History)


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2010-10-03 13:36:12
Сизиф на 64 бита, имеет неработоспособный, на момент подачи этой заявки, арепо
репозиторий (хотя, имхо, стоит, коли это возможно, проверить и арепо
репозитории p5 и 5.1).

К примеру арепнутый флеш требует libcurl (версия которого отсутствует в репе);
а арепнутый wine-vanila требует соответствующую libwine-vanila (которая, в свою
очередь, жалуется на отсутствующие компоненты).

Не могут быть установлены и библиотеки нужные для скайпа...

Возможно есть еще, что-то...

Просто в предверии выхода Кентавра не хотелось бы, что-бы такое попало в его
бранч (ибо тогда, это уже вряд ли, имхо, будет исправлено)...

PS.

Если неправильно выбрал крмпонент в описании, то поправьте, пожалуйста...
------- Comment #1 From 2010-10-03 22:44:00 -------
Компонент вы выбрали правильно, а вот багу отрепортили не лучшим образом.

> libcurl (версия которого отсутствует в репе)

Есть там libcurl:
ftp://ftp.altlinux.ru/pub/distributions/ALTLinux/Sisyphus/x86_32/RPMS.classic/i586-libcurl-7.21.1-alt2.i586.rpm

> которая, в свою очередь, жалуется на отсутствующие компоненты
> Не могут быть установлены и библиотеки, нужные для скайпа...

Так перечислите эти компоненты и библиотеки, я добавлю их в конфиг.

> в преддверии выхода Кентавра не хотелось бы, чтобы такое попало в его бранч

Если вы считаете, что эта бага блокирующая для Кентавра, то добавьте её в
зависимости к #23155.
------- Comment #2 From 2010-10-04 01:42:33 -------
(В ответ на комментарий №1)
> Есть там libcurl:
> ftp://ftp.altlinux.ru/pub/distributions/ALTLinux/Sisyphus/x86_32/RPMS.classic/i586-libcurl-7.21.1-alt2.i586.rpm

Я имел в виду не I586-ой, а "обычный"...

i586-ой требует версию "обычного" строго равную, как помню,
libcurl-7.21.1-alt1.i586, а Сизифе alt2...


> Так перечислите эти компоненты и библиотеки, я добавлю их в конфиг.

Боюсь, в ближайшее время, это сделать мне будет сложно... Так-как, в ближайшее
время, не смогу иметь дел с Сизифом (отчет о баге составлял по горячим
следам)...

Скорее всего проще вам будет (коли имеете возможность "иметь дела с Сизифом");
подключить соответствующий arepo репозиторий, и посмотреть... (благо проблемные
пакеты требующие "неразрешенных зависимостей" названы мною в первом посте
(заодно надо посмотреть, не требует ли их, еще что...)).

Скайп же ставил по инструкции из Вики ( http://www.altlinux.org/Skype ).

> Если вы считаете, что эта бага блокирующая для Кентавра, то добавьте её в
> зависимости к #23155.

Спасибо за совет. Сделал.
------- Comment #3 From 2010-10-04 02:11:36 -------
(In reply to comment #2)
> > Есть там libcurl:
> i586-ой требует версию "обычного" строго равную, как помню,
> libcurl-7.21.1-alt1.i586, а Сизифе alt2...

Понятно. Пакет i586-foo, как правило, зависит от foo той же версии и релиза.
Видимо, у вас был слегка устаревший x86_32 (он обновляется 1 раз в сутки).
Поскольку теперь в нём i586-libcurl-*-alt2, эту проблему считаем закрытой.

> Скорее всего проще вам будет (коли имеете возможность "иметь дела с Сизифом");
> подключить соответствующий arepo репозиторий, и посмотреть... (благо проблемные
> пакеты требующие "неразрешенных зависимостей" названы мною в первом посте
> (заодно надо посмотреть, не требует ли их, еще что...)).

К сожалению, у меня тоже нет под рукой Сизифа. Однако arepo при каждом запуске
проверяет устанавливаемость всех i586-* пакетов, и по состоянию на сегодня всё
устанавливается нормально. См. также #24187, который, возможно, повлиял на ваш
опыт с wine-vanilla, но уже исправлен.

До поступления новой информации считаю баг исчерпанным.