Bug 24219 - installer hangs on radeon 4670 (using recommended driver "radeon")
: installer hangs on radeon 4670 (using recommended driver "radeon")
Status: NEW
: Sisyphus
(All bugs in Sisyphus/installer)
: unstable
: all Linux
: P3 normal
Assigned To:
:
:
:
: 24225
:
  Show dependency tree
 
Reported: 2010-10-04 20:26 by
Modified: 2012-11-28 15:05 (History)


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2010-10-04 20:26:06
пробую altlinux-6.0.0_beta-20101002-kdesktop-i586-ru-install-dvd5.iso 

с видеодрайвером radeon в _инсталляторе_ некая засада:
при выборе пункта "установка" или "установка в безопасном режиме" (одинаково)
грузится до места, где запускает 
x11_autosetup, тот пишет executing x11presetdrv, и следующей строкой 
x11_autosetup: using recommended driver "radeon" with 24bpp color depth и на
этом все виснет.

kms при этом успешно включен, драйвер radeon уже загружен udev-ом ранее, при
включении kms)
nomodeset в параметрах загрузки не действует 
xdriver=vesa в параметрах загрузки действует, вызывая
using explicitly defined driver vesa.. и виснет точно так же.

карта radeon 4670

LiveCD с этого образа успешно работает, с kms, драйвером radeon по умолчанию, с
наличием 3d ускорения через  mesa drm и т.п. все как должно быть (сразу).

установленная ранее система (сизиф) тоже работает с 
GL_RENDERER   = Mesa DRI R600 (RV730 9490) 20090101 x86/MMX+/3DNow!+/SSE2 TCL
DRI2
GL_VERSION    = 2.1 Mesa 7.9
GL_VENDOR     = Advanced Micro Devices, Inc.
------- Comment #1 From 2010-10-04 20:38:27 -------
можно пояснить, почему на propagator ?
------- Comment #2 From 2010-10-04 20:44:37 -------
по этапу очень приблизительно прикинул.
забыл добавить "перевешивайте по желанию" - вам лучше знать, на что.
обычно с вопросом "на что" возникают проблемы ;)
главное - на что-то более точное, а не задвигать "в темный угол подальше с глаз
долой".
------- Comment #3 From 2010-10-05 17:46:12 -------
проверил сейчас на ноутбуке с видеочипом rs690.
в режиме livecd все грузится, как и обещано в mesa 7.9 работает r300g
(показывает gallium 0.4)

в режиме инсталляции тоже грузится, после строки 
x11_autosetup: using recommended driver "radeon" with 24bpp color depth

продолжает с found monitor такой-то, далее про мышь, потом выбирает разрешение
800*600 и стартует xorg.
------- Comment #4 From 2010-10-05 17:51:26 -------
эта проблема очень похожа на
https://bugzilla.altlinux.org/show_bug.cgi?id=24225
------- Comment #5 From 2012-11-28 15:05:15 -------
Возможно, не хватало firmware-linux; насколько понимаю, теперь это WORKSFORME
или WONTFIX.