Bug 24476 - Неудовлетворённые зависимости pkgconfig
: Неудовлетворённые зависимости pkgconfig
Status: CLOSED NOTABUG
: Branch 5.0
(All bugs in Branch 5.0/libgtk+2-devel)
: unspecified
: all Linux
: P3 normal
Assigned To:
:
:
:
:
:
  Show dependency tree
 
Reported: 2010-11-02 05:32 by
Modified: 2010-11-20 10:19 (History)


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2010-11-02 05:32:05
При попытке установить пакет выдаёт:

$sudo apt-get install libgtk+2-devel

Следующие пакеты имеют неудовлетворенные зависимости:
  libgtk+2-devel: Требует: pkgconfig(cairo)
                  Требует: pkgconfig(pango)
                  Требует: pkgconfig(pangocairo)
                  Требует: pkgconfig(pangoft2)
E: Извините, `битые' пакеты

А такие пакеты в репозитории не существует.
------- Comment #1 From 2010-11-02 06:21:19 -------
Если Вы пытаетесь использовать репозоторий 5.0, то ничего хорошего из этого не
выйдет.
Переключите apt на р5 и попробуйте установить требуемый пакет/обновиться.
------- Comment #2 From 2010-11-03 03:42:48 -------
Прошу прощения, но репозиторий на самом деле p5. Просто не увидел Branch p5 и
выбрал Branch 5.0.
------- Comment #3 From 2010-11-12 15:03:57 -------
Сделайте:
apt-get update

Покажите вывод:
grep '^[[:blank:]]*rpm' /etc/apt/sources.list* -R
и
apt-get check
------- Comment #4 From 2010-11-16 19:14:25 -------
$grep '^[[:blank:]]*rpm' /etc/apt/sources.list* -R
/etc/apt/sources.list.d/yandex.list:rpm
http://mirror.yandex.ru/altlinux/p5/branch/ i586 classic  
/etc/apt/sources.list.d/yandex.list:rpm
http://mirror.yandex.ru/altlinux/p5/branch/ noarch classic  
/etc/apt/sources.list.d/alt.list:rpm
http://ftp.altlinux.org/pub/distributions/ALTLinux/p5/branch/ i586 classic  
/etc/apt/sources.list.d/alt.list:rpm
http://ftp.altlinux.org/pub/distributions/ALTLinux/p5/branch/ noarch classic  

# apt-get check
Чтение списков пакетов... Завершено
Построение дерева зависимостей... Завершено
------- Comment #5 From 2010-11-17 09:35:41 -------
Теперь покажите вывод команды:
apt-get install libgtk+2-devel 'pkgconfig(cairo)'

и дальше по цепочке...
------- Comment #6 From 2010-11-18 02:29:32 -------
# apt-get install libgtk+2-devel 'pkgconfig(cairo)'
Чтение списков пакетов... Завершено
Построение дерева зависимостей... Завершено
Выбрано libcairo-devel для 'pkgconfig(cairo)'
Некоторые пакеты установить невозможно. Это может означать, что Вы
потребовали невозможного, либо пользуетесь нестабильным репозиторием.
Часть необходимых пакетов либо ещё не создана, либо была удалена
из каталога 'Входящие'.
Эти сведения могут помочь найти выход из ситуации:

Следующие пакеты имеют неудовлетворенные зависимости:
  libcairo-devel: Требует: pkgconfig(glitz) (>= 0.5.1)
                  Требует: pkgconfig(x11)
                  Требует: pkgconfig(xcb) (>= 0.9.92)
                  Требует: pkgconfig(xcb-render) (>= 0.9.92)
                  Требует: pkgconfig(xcb-renderutil)
                  Требует: pkgconfig(xrender) (>= 0.6)
  libgtk+2-devel: Требует: pkgconfig(pango)
                  Требует: pkgconfig(pangocairo)
                  Требует: pkgconfig(pangoft2)
E: Извините, `битые' пакеты

# apt-get install libgtk+2-devel 'pkgconfig(pangocairo)'
Чтение списков пакетов... Завершено
Построение дерева зависимостей... Завершено
Выбрано libpango-devel для 'pkgconfig(pangocairo)'
Некоторые пакеты установить невозможно. Это может означать, что Вы
потребовали невозможного, либо пользуетесь нестабильным репозиторием.
Часть необходимых пакетов либо ещё не создана, либо была удалена
из каталога 'Входящие'.
Эти сведения могут помочь найти выход из ситуации:

Следующие пакеты имеют неудовлетворенные зависимости:
  libgtk+2-devel: Требует: pkgconfig(cairo)
  libpango-devel: Требует: libX11-devel
                  Требует: pkgconfig(cairo)
                  Требует: pkgconfig(xft)
E: Извините, `битые' пакеты

# apt-get install libgtk+2-devel 'pkgconfig(pangoft2)'
Чтение списков пакетов... Завершено
Построение дерева зависимостей... Завершено
Выбрано libpango-devel для 'pkgconfig(pangoft2)'
Некоторые пакеты установить невозможно. Это может означать, что Вы
потребовали невозможного, либо пользуетесь нестабильным репозиторием.
Часть необходимых пакетов либо ещё не создана, либо была удалена
из каталога 'Входящие'.
Эти сведения могут помочь найти выход из ситуации:

Следующие пакеты имеют неудовлетворенные зависимости:
  libgtk+2-devel: Требует: pkgconfig(cairo)
  libpango-devel: Требует: libX11-devel
                  Требует: pkgconfig(cairo)
                  Требует: pkgconfig(xft)
E: Извините, `битые' пакеты
------- Comment #7 From 2010-11-18 02:34:52 -------
#apt-get install libpango-devel
Чтение списков пакетов... Завершено
Построение дерева зависимостей... Завершено
Некоторые пакеты установить невозможно. Это может означать, что Вы
потребовали невозможного, либо пользуетесь нестабильным репозиторием.
Часть необходимых пакетов либо ещё не создана, либо была удалена
из каталога 'Входящие'.

Так как для выполнения Вашего запроса достаточно одной операции, то
скорее всего этот пакет просто невозможно установить. Сообщите, пожалуйста,
об этом как о найденной ошибке в пакете.
Эти сведения могут помочь найти выход из ситуации:

Следующие пакеты имеют неудовлетворенные зависимости:
  libpango-devel: Требует: libX11-devel
                  Требует: pkgconfig(cairo)
                  Требует: pkgconfig(xft)

# apt-get install libcairo-devel
Чтение списков пакетов... Завершено
Построение дерева зависимостей... Завершено
Некоторые пакеты установить невозможно. Это может означать, что Вы
потребовали невозможного, либо пользуетесь нестабильным репозиторием.
Часть необходимых пакетов либо ещё не создана, либо была удалена
из каталога 'Входящие'.

Так как для выполнения Вашего запроса достаточно одной операции, то
скорее всего этот пакет просто невозможно установить. Сообщите, пожалуйста,
об этом как о найденной ошибке в пакете.
Эти сведения могут помочь найти выход из ситуации:

Следующие пакеты имеют неудовлетворенные зависимости:
  libcairo-devel: Требует: pkgconfig(glitz) (>= 0.5.1)
                  Требует: pkgconfig(x11)
                  Требует: pkgconfig(xcb) (>= 0.9.92)
                  Требует: pkgconfig(xcb-render) (>= 0.9.92)
                  Требует: pkgconfig(xcb-renderutil)
                  Требует: pkgconfig(xrender) (>= 0.6)
------- Comment #8 From 2010-11-18 09:41:11 -------
Делали точечные обновления из других бранчей/Сизифа?

Покажите вывод:
apt-get install libgtk+2-devel 'pkgconfig(cairo)' 'pkgconfig(pangocairo)'
libX11-devel 'pkgconfig(xrender)' 'pkgconfig(xcb-renderutil)' 'pkgconfig(xcb)'
'pkgconfig(x11)' 'pkgconfig(glitz)' 'pkgconfig(xft)'
------- Comment #9 From 2010-11-19 02:27:21 -------
# apt-get install libgtk+2-devel 'pkgconfig(cairo)' 'pkgconfig(pangocairo)'
libX11-devel 'pkgconfig(xrender)' 'pkgconfig(xcb-renderutil)' 'pkgconfig(xcb)'
'pkgconfig(x11)' 'pkgconfig(glitz)' 'pkgconfig(xft)'

Чтение списков пакетов... Завершено
Построение дерева зависимостей... Завершено
Выбрано libcairo-devel для 'pkgconfig(cairo)'
Выбрано libpango-devel для 'pkgconfig(pangocairo)'
Выбрано libXrender-devel для 'pkgconfig(xrender)'
Выбрано libxcbutil-devel для 'pkgconfig(xcb-renderutil)'
Выбрано libxcb-devel для 'pkgconfig(xcb)'
Выбрано libX11-devel для 'pkgconfig(x11)'
Выбрано libglitz-devel для 'pkgconfig(glitz)'
Выбрано libXft-devel для 'pkgconfig(xft)'
Некоторые пакеты установить невозможно. Это может означать, что Вы
потребовали невозможного, либо пользуетесь нестабильным репозиторием.
Часть необходимых пакетов либо ещё не создана, либо была удалена
из каталога 'Входящие'.
Эти сведения могут помочь найти выход из ситуации:

Следующие пакеты имеют неудовлетворенные зависимости:
  libglitz-devel: Требует: libGL-devel
  libxcb-devel: Требует: libxcb (= 1.4-alt1)

Обновиль только ядро до 2.6.32-alt21
------- Comment #10 From 2010-11-19 09:53:20 -------
Покажите вывод:
# rpm -q libxcb

Ну и на всякий случай:
# apt-get install libgtk+2-devel 'pkgconfig(cairo)' 'pkgconfig(pangocairo)'
libX11-devel 'pkgconfig(xrender)' 'pkgconfig(xcb-renderutil)' 'pkgconfig(xcb)'
'pkgconfig(x11)' 'pkgconfig(glitz)' 'pkgconfig(xft)' libGL-devel libxcb
------- Comment #11 From 2010-11-19 18:22:22 -------
# rpm -q libxcb

libxcb-1.7-alt2


# apt-get install libgtk+2-devel 'pkgconfig(cairo)' 'pkgconfig(pangocairo)'
libX11-devel 'pkgconfig(xrender)' 'pkgconfig(xcb-renderutil)' 'pkgconfig(xcb)'
'pkgconfig(x11)' 'pkgconfig(glitz)' 'pkgconfig(xft)' libGL-devel libxcb

Чтение списков пакетов... Завершено
Построение дерева зависимостей... Завершено
Выбрано libcairo-devel для 'pkgconfig(cairo)'
Выбрано libpango-devel для 'pkgconfig(pangocairo)'
Выбрано libXrender-devel для 'pkgconfig(xrender)'
Выбрано libxcbutil-devel для 'pkgconfig(xcb-renderutil)'
Выбрано libxcb-devel для 'pkgconfig(xcb)'
Выбрано libX11-devel для 'pkgconfig(x11)'
Выбрано libglitz-devel для 'pkgconfig(glitz)'
Выбрано libXft-devel для 'pkgconfig(xft)'
Последняя версия libxcb уже установлена.
Некоторые пакеты установить невозможно. Это может означать, что Вы
потребовали невозможного, либо пользуетесь нестабильным репозиторием.
Часть необходимых пакетов либо ещё не создана, либо была удалена
из каталога 'Входящие'.
Эти сведения могут помочь найти выход из ситуации:

Следующие пакеты имеют неудовлетворенные зависимости:
  libGL-devel: Требует: libdrm-devel
  libxcb-devel: Требует: libxcb (= 1.4-alt1)

Блин, теперь всё понятно.
Извините за потраченное время
------- Comment #12 From 2010-11-20 10:19:53 -------
(В ответ на комментарий №11)
> # rpm -q libxcb
> 
> libxcb-1.7-alt2 
> 
> Следующие пакеты имеют неудовлетворенные зависимости:
>   libGL-devel: Требует: libdrm-devel
>   libxcb-devel: Требует: libxcb (= 1.4-alt1)
> 
> Блин, теперь всё понятно.
> Извините за потраченное время

А говорите точечных обновлений не делали ;)