Bug 24701 - xorg abnormally crashes
Summary: xorg abnormally crashes
Alias: None
Product: Sisyphus
Classification: Development
Component: xorg (show other bugs)
Version: unstable
Hardware: all Linux
: P3 normal
Assignee: Valery Inozemtsev
QA Contact: qa-sisyphus
Depends on:
Reported: 2010-12-06 14:48 MSK by Alex Negulescu
Modified: 2010-12-11 12:03 MSK (History)
2 users (show)

See Also:

xorg crash log (17.61 KB, text/plain)
2010-12-06 14:48 MSK, Alex Negulescu
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Alex Negulescu 2010-12-06 14:48:34 MSK
Created attachment 4690 [details]
xorg crash log

Xorg crashes when clicking different aps with nvidia driver in dual monitor, twinview.
Can be reproduced by:
- run acc
- click ethernet interfaces
- click advanced (if it does not crash, try selecting NetworkManager, etcnet - it sure crashes)


- run smplayer
- click options, preerences

Kernel and driver:

It also does it on:
Comment 1 Valery Inozemtsev 2010-12-06 16:14:29 MSK
проблемы проприетарных драйверов никому не интересны
Comment 2 Alex Negulescu 2010-12-07 12:40:43 MSK
It's a xorg issue. It does the same with older drivers from nvidia (like 256.53 which was very stable for me on 32bit), and all the drivers tested worked ok on older xorg versions.

Tested and crashed on:
X.Org X Server (1.9.3 RC 1)
Release Date: 2010-11-13
X Protocol Version 11, Revision 0
Build Operating System: ALT Linux Sisyphus (20081222) x86_64
- 260.19.21
- 256.53 (built by hand)
- 190.53 (built by hand)

Tested and worked on:
X.Org X Server 1.6.5
Release Date: 2009-10-11
X Protocol Version 11, Revision 0
Build Operating System: Simply GNU/Linux 5.0.0 RC2 (Billy) x86_64
- 260.19.21 from apt repo
- 256.53  from apt repo
- 190.53  from apt repo

It will be probably fixed by the next release of xorg. I searched and we (ALT) are not the only ones with issues with the last xorg.
Comment 3 Valery Inozemtsev 2010-12-07 12:51:46 MSK
могу только предложить потестировать 1.10 RC1
Comment 4 Alex Negulescu 2010-12-07 12:57:20 MSK
Если у вас есть время, может сделать.
Я снижен до 1.6.5.

Comment 5 Valery Inozemtsev 2010-12-07 14:56:11 MSK
Comment 6 Alex Negulescu 2010-12-08 20:19:12 MSK
Tried 7.6, could not use it with proprietary driver because of the ABI of Xorg. Once with the new version of xorg ( (1.9.3 RC 2)), all works well, with proprietary.