Bug 2481 - g++ не находит системных инклюдов
: g++ не находит системных инклюдов
Status: CLOSED WORKSFORME
: Sisyphus
(All bugs in Sisyphus/gcc3.2-c++)
: unstable
: all Linux
: P4 major
Assigned To:
:
:
:
:
:
  Show dependency tree
 
Reported: 2003-04-06 04:01 by
Modified: 2003-08-25 15:18 (History)


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2003-04-06 04:01:57
[<a href="mailto:akhavr@netmaster" target="_new">akhavr@netmaster</a> RPM]$
sudo /usr/sbin/select-gcc 3.2
Using `/usr/bin/i586-alt-linux-cpp-3.2\' to provide `i586-alt-linux-cpp\'.

Using `/usr/bin/i586-alt-linux-gcc-3.2\' to provide `i586-alt-linux-gcc\'.

Using `/usr/bin/i586-alt-linux-g++-3.2\' to provide `i586-alt-linux-g++\'.

Using `/usr/bin/i586-alt-linux-g77-3.2\' to provide `i586-alt-linux-g77\'.

[<a href="mailto:akhavr@netmaster" target="_new">akhavr@netmaster</a> RPM]$
echo \&quot;#include &lt;bits/c++config.h&gt;\&quot; | /usr/bin/g++-3.2  -E
-xc++ - 
# 1 \&quot;&lt;stdin&gt;\&quot;
# 1 \&quot;&lt;built-in&gt;\&quot;
# 1 \&quot;&lt;command line&gt;\&quot;
# 1 \&quot;&lt;stdin&gt;\&quot;
&lt;stdin&gt;:1:28: bits/c++config.h: No such file or directory
[<a href="mailto:akhavr@netmaster" target="_new">akhavr@netmaster</a> RPM]$ rpm
-qf /usr/bin/g++-3.2 
gcc3.2-c++-3.2.1-alt2
[<a href="mailto:akhavr@netmaster" target="_new">akhavr@netmaster</a> RPM]$
find /usr/include/ -name c++config.h
/usr/include/c++/3.2.1/i586-alt-linux/bits/c++config.h
[<a href="mailto:akhavr@netmaster" target="_new">akhavr@netmaster</a> RPM]$ rpm
-qf /usr/include/c++/3.2.1/i586-alt-linux/bits/c++config.h 
libstdc++3.2-devel-3.2.1-alt2

---

---
------- Comment #1 From 2003-06-20 15:01:46 -------
Unable to reproduce this.
------- Comment #2 From 2003-06-20 15:01:46 -------
Unable to reproduce this.