Bug 24812 - typo in redhat-add_ip.sh
: typo in redhat-add_ip.sh
Status: CLOSED FIXED
: Sisyphus
(All bugs in Sisyphus/vzctl)
: unstable
: all Linux
: P3 normal
Assigned To:
:
:
:
:
:
  Show dependency tree
 
Reported: 2010-12-23 18:19 by
Modified: 2010-12-25 03:13 (History)


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2010-12-23 18:19:07
досадная ошибка не поднимает роут в RH-based контейнерах.
Странно, почему раньше работало. Обнаружилось при переходе на 2.6.32-ovz-el и
vzctl-3.0.24.1-alt1

--- redhat-add_ip.sh.old    2010-08-11 04:10:28.000000000 +0400
+++ redhat-add_ip.sh    2010-12-23 18:00:38.000000000 +0300
@@ -52,7 +52,7 @@
     # Set /etc/sysconfig/network
     put_param $NETFILE NETWORKING yes
     # Set default route to venet0
-    put_param $NETFILE GATEWAYDEV ${VENETDEV}
+    put_param $NETFILE GATEWAYDEV ${VENET_DEV}
     # Remove old (obsoleted) fake route
     del_param $NETFILE GATEWAY
     [ -f "${IFCFG_DIR}/route-venet0" ] && rm -f ${IFCFG_DIR}/route-venet0
------- Comment #1 From 2010-12-23 18:52:22 -------
Исправлено в апстриме:
605cbffedea031dbcb600a1798875794add981da
------- Comment #2 From 2010-12-23 23:34:11 -------
*** Bug 24813 has been marked as a duplicate of this bug. ***
------- Comment #3 From 2010-12-25 03:13:31 -------
vzctl-3.0.24.2-alt1 -> sisyphus:

* Fri Dec 24 2010 Dmitry V. Levin <ldv@altlinux> 3.0.24.2-alt1
- Updated to vzctl-3.0.24-42-gf3bf518+3.0.24.2 (closes: #24812).