Bug 24958 - update to 8.36
: update to 8.36
Status: CLOSED FIXED
: Sisyphus
(All bugs in Sisyphus/libpcre3)
: unstable
: all Linux
: P3 enhancement
Assigned To:
:
: http://www.pcre.org/news.txt
:
:
:
  Show dependency tree
 
Reported: 2011-01-22 18:35 by
Modified: 2015-05-26 19:55 (History)


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2011-01-22 18:35:35
Release 8.12 15-Jan-2011
------------------------

This release fixes some bugs in pcregrep, one of which caused the tests to fail
on 64-bit big-endian systems. There are no changes to the code of the library.


Release 8.11 10-Dec-2010
------------------------

A number of bugs in the library and in pcregrep have been fixed. As always, see
ChangeLog for details. The following are the non-bug-fix changes:

. Added --match-limit and --recursion-limit to pcregrep.

. Added an optional parentheses number to the -o and --only-matching options
  of pcregrep.

. Changed the way PCRE_PARTIAL_HARD affects the matching of $, \z, \Z, \b, and
  \B.

. Added PCRE_ERROR_SHORTUTF8 to make it possible to distinguish between a
  bad UTF-8 sequence and one that is incomplete when using PCRE_PARTIAL_HARD.

. Recognize (*NO_START_OPT) at the start of a pattern to set the PCRE_NO_
  START_OPTIMIZE option, which is now allowed at compile time
...
------- Comment #1 From 2011-01-23 00:14:59 -------
ok
------- Comment #2 From 2011-01-23 00:47:11 -------
pcre-8.12-alt1 -> sisyphus:

* Sun Jan 23 2011 Dmitry V. Levin <ldv@altlinux> 8.12-alt1
- Updated to 8.12 (closes: #24958).
------- Comment #3 From 2012-03-05 19:04:42 -------
Новой glib2 нужен pcre-8.30. Прошу обновить.
------- Comment #4 From 2015-04-21 17:53:34 -------
а можно обновить до 8.36? 
А то у меня аналогичная проблема (нужен pcre_stack_guard)
https://bugs.mageia.org/show_bug.cgi?id=12665
А собирать с локальной копией не хочется.
------- Comment #5 From 2015-04-22 00:44:57 -------
[мантейнер в отпуске]
------- Comment #6 From 2015-05-26 19:55:11 -------
pcre-8.37-alt2 -> sisyphus:

* Tue May 26 2015 Dmitry V. Levin <ldv@altlinux> 8.37-alt2
- Bumped libpcrecpp soname due to libstdc++ ABI change.

* Tue May 26 2015 Dmitry V. Levin <ldv@altlinux> 8.37-alt1
- Updated to 8.37 (closes: #24958).