Bug 25052 - no AR2427 support (ath9k module)
: no AR2427 support (ath9k module)
Status: CLOSED WONTFIX
: Sisyphus
(All bugs in Sisyphus/kernel-image-el-smp)
: unstable
: all Linux
: P3 normal
Assigned To:
:
:
:
:
:
  Show dependency tree
 
Reported: 2011-02-08 19:15 by
Modified: 2014-05-02 00:11 (History)


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2011-02-08 19:15:11
Скачал centaurus 6 livecd beta последний на данный момент. 
загрузил его с флешки на нетбуке ASUS 1001PX

беспроводной сети нет как класса. А именно:
02:00.0 Network controller: Atheros Communications Inc. AR2427 Wireless Network
Adapter (PCI-Express) (rev 01)
    Subsystem: AzureWave Device 1112

(модуля нет)
Linux localhost.localdomain 2.6.32-el-smp-alt13 #1 SMP Tue Jan 25 13:09:46 UTC
2011 i686 GNU/Linux
(версия ядра в этой сборке)

чтобы была, нужно собрать ath9k (в ядре, модулем..)
http://wireless.kernel.org/en/users/Drivers/ath9k

supported chipsets

Legacy:
    AR2427 (>= 2.6.32.16, no 802.11n hardware support, its bonded out)
------- Comment #1 From 2011-02-08 19:34:02 -------
# find /lib/modules/2.6.32-el-smp-alt13/ -name "ath9k.ko"
/lib/modules/2.6.32-el-smp-alt13/kernel/drivers/net/wireless/ath/ath9k/ath9k.ko

модуль на месте.
------- Comment #2 From 2011-02-08 19:37:33 -------
перейдем тогда к другому вопросу - как видно из lspci -k, он не грузится.

в результате wifi не работает. можно перевесить на тот компонент, который
виноват.
------- Comment #3 From 2011-02-08 19:39:40 -------
а если вручную сказать modprobe ath9k ?
------- Comment #4 From 2011-02-08 21:31:07 -------
попробовал. модуль молча грузится. ничего больше не происходит (устройство он
не цепляет)

устройство с id 
0280: 168С:002с
Subsystem 1a3b:1112

в списке modinfo alias варианта 2С как раз почему-то нет, хотя 2B, 2D есть
------- Comment #5 From 2011-02-08 22:07:18 -------
в eeepc-live с ядром 2.6.36 в списке alias это устройство есть, wifi интерфейс
появляется.
с беспроводной сетью соединяется.

видимо, в 2.6.32 старая версия ath9k.
------- Comment #6 From 2011-02-09 00:11:51 -------
Существует 2 варианта решения ваше проблемы:
1 быстрый - поставить ядро другого flavour (к примеру - un-def)
2 ждать пока апстрим (RH) обновит ath9k. Не факт, что это вообще случится.
поэтому пока RESOLVED/LATER
------- Comment #7 From 2011-02-09 09:19:28 -------
в случае с этим ядром - понятно, да, что теперь "ждем апстрим"..

но куда бы повесить баг о том, что использовать такое ядро с "задержками от
апстрима" в релизе дистрибутива centtaurus 6  - неверно?
------- Comment #8 From 2011-02-09 10:09:35 -------
Всегда существует некий trade-off между стабильностью и подержкой самых новых
фич. Для серверного LTS-дистрибутива стабиьность перевешивает.
------- Comment #9 From 2014-05-02 00:11:22 -------
Да, для новых wifi лучше применять un-def/led-ws.