Bug 2554 - не работает команда mkchroot
: не работает команда mkchroot
Status: CLOSED NOTABUG
: Sisyphus
(All bugs in Sisyphus/pkg-build-utils)
: unstable
: all Linux
: P5 major
Assigned To:
:
:
:
:
:
  Show dependency tree
 
Reported: 2003-04-29 23:36 by
Modified: 2007-04-06 16:13 (History)


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2003-04-29 23:36:43
pkg-build-utils-0.0.3-alt1
не отрабатывает команда mkchroot, падает с сообщениями:
 prefix mismatch
status for /usr/lib/pkg-build-priv/makedev.sh  /build/bte/tmp/bte/chroot is 1
Exception `Subprograms::ExecutionError\' at /usr/share/ruby/vendor_ruby/1.7/bte/subprogram.rb:51 - Execution of </usr/lib/pkg-build-priv/makedev.sh  /build/bte/tmp/bte/chroot> return rc=1
BTE: Unhandled error
BTE: Execution of </usr/lib/pkg-build-priv/makedev.sh  /build/bte/tmp/bte/chroot> return rc=1
/usr/share/ruby/vendor_ruby/1.7/bte/subprogram.rb:51:in `execute\'
BTE: Err: /usr/share/ruby/vendor_ruby/1.7/bte/helpers.rb:24:in `priv_run\'
BTE: Err: /usr/share/ruby/vendor_ruby/1.7/bte/helpers.rb:46:in `mkdev\'
BTE: Err: /usr/share/ruby/vendor_ruby/1.7/bte/chroot.rb:196:in `bootstrap\'
BTE: Err: /usr/share/ruby/vendor_ruby/1.7/bte/mkchroot.rb:15:in `prepare\'
BTE: Err: /usr/share/ruby/vendor_ruby/1.7/bte/mkchroot.rb:104:in `build\'
BTE: Err: /usr/share/ruby/vendor_ruby/1.7/bte/builder.rb:56:in `build\'
BTE: Err: /usr/share/ruby/vendor_ruby/1.7/bte/builder.rb:55:in `each\'
BTE: Err: /usr/share/ruby/vendor_ruby/1.7/bte/builder.rb:55:in `build\'
BTE: Err: /usr/bin/pkg-build:206

При этом команда build работает нормально

---

---

------- Comment #1 From 2003-04-30 15:43:33 -------
Message caused by misconfiguration
Wrong workdirectory specified or missed workdir
------- Comment #2 From 2003-04-30 15:43:33 -------
Message caused by misconfiguration
Wrong workdirectory specified or missed workdir